Gurshinder03
Participant
  • 0
  • 1
  • 0
Registered since

Nov 1, 2020

Soundsport free left earbud buzzing and not turning on

Recently, my left Soundsport Free earbud has stopped turning on and starts buzzing when I press the bluetooth button. A few days ago it had started working again but has now gone back to the same condition. Pls help as I really need them.

1 ACCEPTED SOLUTION

Accepted Solutions
Alan_L
Participant
  • 0
  • 2
  • 1
Registered since

Nov 3, 2020

Re: Soundsport free left earbud buzzing and not turning on

Author Accepted Answer selected by Gurshinder03

And FYI, the BOSE updater on the link above does not work.  Error message "Bose updater is not working, please try later" And the download App does not open on PC either.  Pretty pathetic support in my opinion.  Care to prove otherwise?

 

View solution in original post

4 REPLIES 4
Hector_B
Moderator

Re: Soundsport free left earbud buzzing and not turning on

Hello Gurshinder03, 

 

Thank you for posting and welcome to the Bose Community. I'm sorry to read that you are having a power issue with your SoundSport Free. 

 

Can you please let us know if you see any LED indicators on the earbud when attempting to charge or power it on? Let's attempt to see if you are able to update the headset at all, to perform this step please connect the headset to a PC/Mac via the USB charging cable. Once connected please visit our online updater and follow the on-screen instructions. 

 

We look forward to hearing back from you with further information. 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Alan_L
Participant
  • 0
  • 2
  • 1
Registered since

Nov 3, 2020

Re: Soundsport free left earbud buzzing and not turning on

Hi, I am having exactly the same problem and have been waiting to see the original OP reply, however, that has not happened.  In my situation I have all LEDs showing that 1. THe charging is happening and 2. Both LEDs are 'on' after charge is complete.  But wehn trying to switch on the left bud, I get a continual buzz and it cannot connect to my device, it remains dead.

Alan_L
Participant
  • 0
  • 2
  • 1
Registered since

Nov 3, 2020

Re: Soundsport free left earbud buzzing and not turning on

Author Accepted Answer selected by Gurshinder03

And FYI, the BOSE updater on the link above does not work.  Error message "Bose updater is not working, please try later" And the download App does not open on PC either.  Pretty pathetic support in my opinion.  Care to prove otherwise?

 

View solution in original post

Keith_L
Community Manager

Re: Soundsport free left earbud buzzing and not turning on

Hi Alan_L,

 

It's strange that the updater is not working on your computer. What web browser have you been using when accessing the updater? Have you tried it with any others? I tend to use Google Chrome when I use the updater, so if you have been using another browser it would be worth trying on Google Chrome.

 

I'd also recommend performing a reset of your headphones. To do this what you will want to do is:

  • Place your earbuds in the charging case
  • Connect the charging case to a wall outlet using a USB charger, then wait five seconds
  • Disconnect the USB cable from the charging case, then wait one minute
  • Remove your earbuds from the case

Let me know how you get on!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!