soundsport wireless does not power on

Highlighted
Silent Starter

soundsport wireless does not power on

Hello, my soundsport wireless headphones will not power on. Yesterday I updated the firmware to the latest version. I left them to charge overnight, plugged into a wall outlet via USB cable. The LED was green this morning while still plugged into the outlet, but once I removed them from the USB cable and pressed the power button, no LED at all was illuminated.

Also, I am unsure where on the headphones the serial number is located. I no longer have the original packaging.

Looking forward to hearing from you, as I did enjoy using these headphones, and Bose usually is a reliable brand. Thank you.

110 REPLIES
Audible Advocate

SoundSport not powering on despite full charge

Hello --

 

I just went to turn on my soundsport headphones for my bike ride home from the office and, to my dismay, they refuse to power on - despite being at a 90% charge when I turned them off this morning.

 

They've had a few glitches lately that I didn't take too much notice of - namely, turning off mid-bike ride and not turning on again for several minutes. Hoping for an easy solution.

 

Thanks,

Kara

Moderator

Re: SoundSport not powering on despite full charge

karakowski

 

 

Thanks for the post. First lets reboot the headset,
  
1.Turn the headset off and wait for 30 seconds.
2.Plug the headset into a USB power supply via USB cord and wait 5 seconds. (Power supply needs to be plugged into the wall with power on).
3.Unplug USB cord from headset and wait 1 minute.
4.Turn on the headset and test if the headset works properly

 

Let us know if that helps.

 

Tony

Audible Advocate

Re: SoundSport not powering on despite full charge

No dice. Thanks anyways!

Moderator

Re: SoundSport not powering on despite full charge

Kara,

 

Thanks for trying that. Sorry it didn't help. We would suggest contacting your local Bose support by going HERE. Click on your country, scroll down to "Contact Us"

 

 

Let us know how it worked out

 

Tony

Audible Advocate

Re: SoundSport not powering on despite full charge

I face the same issue. The soundsport worked fine for sometime a few months flawlessly. There were a few connection problems, or connection dropping here and there once in a while but it was all good. After few months, it just won't start up now. Whenever I put it on charge it will always show me the green light, but never turn on. I had also updated it regularly but past 2 months, its just eating dust at my desk because it won't turn on.

Definitely the worst Bose product I have ever owned. 

This doesn't ends here. Before 2 months when it was at  least letting me play some music, after charging it fully, it would play great music and then when i turn it off , it won't start again. Buggiest product ever. I own have owned 5 bose earphones and still own 2 more, but this is the worst.

I contacted the support team, and they asked me to update the firmware, it resolved the issue for sometime, and after that it was back to square one.

I bought the soundsport in July 2016, it worked fine till about November 2016, and ever since it's been nothing but a rubbish for me.

 

Can anyone help? Or do i just get these changed, if i'm eligible for a change.

Moderator

Re: SoundSport not powering on despite full charge

ab15

We have direct messaged you about this.

Tony

Silent Starter

Re: SoundSport not powering on despite full charge

This just happened to me. I Charge them, green light is on - then I cannot turn them on.

I got "lucky" one time - I unplugged them and they immediately started connecting. This is something that has been happening for a LONG TIME now - I charge them then throw them in my bag - but strangely - they were still ON! Even though I turned them OFF before charging them.

 

Anyway - when this luckily happened today - they were charging and when I unplugged them they connected - they had about 30% charge. Strange, because the light is green. Thinking everything was OK I listened for about an hour then had to run to a meeting - so I connected them to the USB charger again (have tried PC and WALL) and now - the light is green - but disconnecting does not solve the problem, and mashing the button does not solve the problem. 

 

What is to be done? Get an exchange?

Moderator

Re: SoundSport not powering on despite full charge

TokyoMike

 

Sorry to hear that. Based on what you are describing, we would recommend contacting your local Bose support by going HERE. Click on your country, scroll down to "Contact Us"

 

Thanks

 

Tony

Quiet Contributor

Re: SoundSport not powering on despite full charge

This happened to me, well sorta...

A few times I have had an issue where the battery would discharge, and the unit wouldn’t turn on..

I’d plug it into the wall, it’d blink Amber a few times before ultimately turning solid red (or no color at all)

The solution for me, was to interrupt the sequence via the play/pause button. I noticed that the sequence was 5 amber blinks followed by solid red light (error) ..

When it goes into error mode it prevents the battery from charging (from what I can gather) so my solution was to interrupt the sequence.

On the 5th amber blink, I would tap the play/pause, and it would start blinking orange again.. do this for about 5 minutes (10-15 times) every 5th amber blink...

It sounds crazy and there was no real solution via Bose customer service or anywhere online — but it has worked twice for me now when I was almost positive the unit was dead.

Good luck!

@datsko