Bose Soundlink Revolve Charging Still an issue

Highlighted
Quiet Contributor

Bose Soundlink Revolve Charging Still an issue

Hi,

 

This happened previously too. The speaker keeps charging (amber light) at 90% and never reaches 100%. Last time I did firmware update and reset it worked. It started again yesterday, I did a reset like last time but to no use. It still stuck at 90%. Anyone facing the issue recently? Mods please help.

3 REPLIES
Moderator

Re: Bose Soundlink Revolve Charging Still an issue

Hi ArjunBhattacharjee,

 

Thanks for reaching out. I am so sorry to hear about that. Let's see what we can do. You mention that you tried resetting, but have you tried restoring the speaker to factory defaults?

 

To restore to the factory default settings:

 

Note: A restore clears the paired Bluetooth device memory and the language settings from the speaker, returning it to its original factory settings. 

  • Turn the speaker on
  • Press and hold the Power button for 10 seconds

Once complete, the Bluetooth indicator flashes blue and a voice prompt prompts to select a language
 

Regards,

 

Tony G - Community Support

CEA
Silent Starter

Re: Bose Soundlink Revolve Charging Still an issue

I just had the same issue, and doing a reset did not help. I 'fixed' it for now by re-applying the firmware.  To do this, I did the following:

  1. Start the BOSE Update Software webservice (http://www.bose.com/btu), plug in the Revolve
  2. Confirmed “Your product is up to date. Your software is up to date.”
  3. Press the following keys on your keyboard to get to the advanced mode menu: A  - D - V - Arrow Up - Arrow Down (need to use caps)
  4. Click the dropdown menu beneath the line "Update software version to:" and reselect the current firmware
  5. Click the green button called "Apply changes »" and wait until the firmware is transferred / installed

 

After I did this, the Revolve started gave the two tone indication that it was charging, and charged up to 100%.

Moderator

Re: Bose Soundlink Revolve Charging Still an issue

Hello CEA,

 

Thank you for the update on what resolved it for you. 

 

I'm sure this will be beneficial to other community members as well.

 

Regards,

Joel - Community Support