cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
AdrianMulvey
Participant
  • 0
  • 3
  • 0
Registered since

Jun 6, 2009

Bose L1 Model II

Hi Folks,

Just spent 2 hours on hold to Bose UK from Ireland 😞  That will be an expensive call. Then just got cut off !

I have a Bose L1 Model II and has been working fine for a few years. ( Bought it brand new ). 

Tried to power it on today and nothing happened for about a minute then the power light came on ( Blue ) after a minute. Then after about a further 30 seconds quite a loud buzz coming from the towers and the light on the main unit still Blue. Loud noise remains until I turn unit off. 

I have removed all connections to Desk / Bass unit etc .. 

I have tried different Sockets / Different Power Cables. 

Issue remains. 

Any ideas what this might be or what this particular sequence of events might mean ? Was working perfect up to yesterday. 

 

Please help !

Thanks folks. 

3 REPLIES 3
AdrianMulvey
Participant
  • 0
  • 3
  • 0
Registered since

Jun 6, 2009

Re: Bose L1 Model II

Anybody ??

scotthanna
Advocate
  • 29
  • 603
  • 4
Registered since

May 20, 2006

Re: Bose L1 Model II

Hello Adrian,

I'm sorry to hear you are having trouble. Unfortunately, calling bose service is the best option. I've owned my systems for 12 years and have never had the issue or heard of anyone else having it. 

What did Bose recommend in the time you were talking to them?

brigbaker
Participant
  • 1
  • 1
  • 0
Registered since

Jul 21, 2021

Re: Bose L1 Model II

My guitarist had this issue and it ended up being his base unit.

He had to return his base unit and it was repaired. This was all paid for under warranty.

He has not had any further issues.

 

I hope this helps.