Member
  • 0
  • 2
  • 0
Registered since

Mar 14, 2020

L1 and T8S distortion issues

Vocals on my L1 used to be pristine and clear, but now distortion (digital distortion sound) from L1 tower intermittently at the transient point when a person sings. It happens only with vocal signals and not with instruments. All levels are properly set. The "green/red" signal light on the L1 base stays green when distortion sound occurs. Any on else experience this? Any suggestion of what the problems is?

 

I am using a Bose T8S Tonematch mixing board with very little effect other than a small amount of reverb.  

 

Thanks.

1 REPLY 1
Highlighted
Professional Legend
  • 1412
  • 48121
  • 1
Registered since

May 11, 2020

Re: L1 and T8S distortion issues

Hi, Kerry Neff.

I'm sorry you are having a problem with the vocals through your T8S and L1 Model II.

@Kerry Neff posted:

Vocals on my L1 used to be pristine and clear, but now distortion (digital distortion sound) from L1 tower intermittently at the transient point when a person sings. It happens only with vocal signals and not with instruments.

Have you changed ANYTHING in your setup lately?

Please try a different microphone, microphone cable, and different channel on the T8S and check out this video 



All levels are properly set. The "green/red" signal light on the L1 base stays green when distortion sound occurs. Any on else experience this? Any suggestion of what the problems is?

Please review the settings for connections here: T8S to L1 Model II



I am using a Bose T8S Tonematch mixing board with very little effect other than a small amount of reverb.  

Thanks.

Please make sure you have the latest firmware.

T4S/T8S Firmware Update Instructions



Thanks,



ST