• 0
  • 1
  • 0
Registered since

Sep 13, 2020

S1 Pro Service Port Not Working - Early 2018 Version

I purchased one of the early versions of the Bose S1 Pro.  Documentation indicates you need to update the firmware using the USB cable connected to the service port.  I also bought a 2nd S1 Pro a year later.  The 2nd S1 Pro I can connect to my MacBook and run the update successfully.  The original S1 does not recognize it's connected.  Same cable, computer and approach.  Tried removing battery, charging fully, different Windows computer with the same issue.  The updater does not recognize it's connected to the service port.  Please help!  I'm starting to think the 1st versions had different hardware or firmware and it's a hardware issue.  


Re: S1 Pro Service Port Not Working - Early 2018 Version

Hi GuitarKing,

Welcome to the forum, thanks for joining us! 

I'm sorry to hear you're experiencing this problem. If you've tried a different cable and a different computer, this would certainly point towards the service port on the speaker itself being the root of the problem.

I recommend contacting Bose customer support and booking a repair to get this fixed. A software upgrade can also be performed as part of a repair service on the S1 Pro.

Hope this helps!