cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
iainr1
Member
  • 0
  • 23
  • 0
Registered since

Dec 6, 2007

T1 blue screen, seems to have failed

One of my T1 units shows only a blue screen when it's powered up. Nothing on the display screen, no response when any of the buttons etc are pressed.

I've tried connecting it to my Mac via USB and running the T1, but I get the message "No compatible Bose USB device found".

Is there a way to carry out a hardware reset?

I bought it from Bruce Millers / Aberdeen / UK, which has now sadly gone into receivership.

Many thanks

Iain
4 REPLIES 4
dibobbio
Contributor
  • 0
  • 206
  • 0
Registered since

Jul 16, 2014

Re: T1 blue screen, seems to have failed

Hi IainR,

I'm sorry to hear about the issue. To reset the T1, disconnect its power cord for at least one minute. If you have done this already or if you try it and it doesn't resolve the issue, please contact us by phone so we can discuss the issue further. Our contact info can be found here: http://www.bose.co.uk/GB/en/contact-us/

Thank you,
iainr1
Member
  • 0
  • 23
  • 0
Registered since

Dec 6, 2007

Re: T1 blue screen, seems to have failed

Unfortunately disconnecting the power doesn't fix it. Thanks for the reply, I'll get in touch by phone.
- Iain
jj2man
Participant
  • 0
  • 1
  • 0
Registered since

Sep 13, 2020

Re: T1 blue screen, seems to have failed

Hello,

 

I am experiencing the same blue screen issue. I have tried unplugging, but no such luck. It started happening after I used a different power cord (The one with 2 female prongs at the end) and plugged it in.

 

I called BOSE and they said the only way to fix it is to mail it to them and pay $100 and the repair can take several weeks. Any help is appreciated!

Dylan_R
Moderator

Re: T1 blue screen, seems to have failed

Hi jj2man,

Thanks for commenting, welcome to the forum! 

If the issue only began after trying a different power cord, I recommend replacing this cord first If it's clear the issue lies with the T1 mixer itself, then the repair service would be the next step.

Hope this helps!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply. If you see a post you like, make sure to give it a thumbs up!