Highlighted
Professional Legend
  • 1407
  • 48121
  • 1
Registered since

May 11, 2020

ToneMatch Updater

The ToneMatch Updater application replaces the L1 Updater. 

Use it to update the firmware on your T1/T4S/T8S ToneMatch mixers. There's a new user interface and it works with Windows and macOS.

You can see it in action in the video below.

Get the application and firmware updates for the T4S/T8S here

T4S/T8S Firmware Update Instructions

What version do you have?

On your ToneMatch mixer

  • Turn the Rotary Selector to Prefs
  • Turn the Menu selector to Versions
  • Press Select
  • Read the version number



If you have a T4S/T8S make sure you have firmware version 1.1.4 that was released in November 2018.

If you have a T1 and the firmware is 1.8, you don't need to do an update.

ST

6 REPLIES 6
Highlighted
Member
  • 4
  • 10
  • 0
Registered since

Jun 18, 2018

Re: ToneMatch Updater

So, is version 1.1.4 the current version for the T8S?  Your wording above confuses me because you are advising us to update if we haven't updated since November 2018 (version 1.1.4).  I have NOT "updated my firmware since November 2018 (version 1.1.4)" because I already have that version loaded.  I believe it would be clearer if you had said "if you have not updated your T4S/T8S with version 1.1.4 (released in November 2018), then you should do that now."   Please clarify.  Thanks!

Highlighted
Professional Legend
  • 1407
  • 48121
  • 1
Registered since

May 11, 2020

Re: ToneMatch Updater

Thanks Rotnick,

I have updated the text in my post above.

ST

Highlighted
Member
  • 4
  • 10
  • 0
Registered since

Jun 18, 2018

Re: ToneMatch Updater

thanks for your patience with us.  That definitely clarifies it for me.

 

Highlighted
Advocate
  • 63
  • 228
  • 1
Registered since

Mar 29, 2010

Re: ToneMatch Updater

@ST My T1 says the version is 1.8, so I guess I don't need to worry about an update.

Highlighted
Participant
  • 5
  • 163
  • 0
Registered since

Jun 22, 2019

Re: ToneMatch Updater

Hi ST. When I got my T8S back from Base repair, there was a note in the box that said unit has been checked and all updates installed. So when I turned on the T8S it still has 1.4 Then I went to check my TI and it shows DSP Firmware 1.8, Power stand 1.5. Remember I am using B2 for subs so I'm pretty sure I will need 1.8 for them in order to use all options on the back of the B2 and according to the B2 manual. **** I'm having fun.

Highlighted
Professional Legend
  • 1407
  • 48121
  • 1
Registered since

May 11, 2020

Re: ToneMatch Updater

Hi Chuckm,

Everything is up to date.  The firmware versions are different for different devices. 

Chuckm posted:

Hi ST. When I got my T8S back from Base repair, there was a note in the box that said unit has been checked and all updates installed. So when I turned on the T8S it still has 1.4

T8S: The latest firmware is version 1.1.4

Then I went to check my TI and it shows DSP Firmware 1.8,

T1:  The latest firmware is version 1.8

Power stand 1.5. Remember I am using B2 for subs so I'm pretty sure I will need 1.8 for them in order to use all options on the back of the B2 and according to the B2 manual. **** I'm having fun.

L1 Model II Power Stand: The latest firmware version is 1.5

For those reading along - if you have L1 Model II Power Stand version 1.4 you have the latest user-installable version.

ST