Highlighted
Participant
  • 0
  • 9
  • 0
Registered since

Jul 24, 2020

Bose Connect party mode stopped working

Bose Connect has just updated. Party mode no longer works. Both of my Revolve+ units are connected via Bluetooth and Connect picks up whichever one is powered up first. (Turn one off and it immediately connects to the other) When I try to start Party Mode, the search screen repeatedly scrolls left sometimes showing the nickname of one speaker at the top then the other. After a few moments it all scrolls back again to the main screen but no party mode. The other odd thing is that the button clicks come out of the opposite speaker to the one shown as connected. Android on a Samsung A8 phone.

13 REPLIES 13
Highlighted
Moderator

Re: Bose Connect party mode stopped working

Hi JWalters1955,

 

Sorry to hear you're having issues with party mode, I'd love to help!

 

Have you tried using the Bose Connect app on an alternate device?

When you get the failed connection, is the app stating the speakers are connected but no music continues to play? Do you get any error messages?

 

Something I would suggest is rebooting your mobile device, it may also be worth resetting your speakers too. To factory reset your speakers, please follow the below instruction;

  • Power on your product
  • Press and hold the Power button for about 10 seconds until the Bluetooth® light blinks blue and a voice prompt instructs you to select a language

I look forward to hearing from you.😊

 

 

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!
Highlighted
Participant
  • 0
  • 9
  • 0
Registered since

Jul 24, 2020

Re: Bose Connect party mode stopped working

Tried all of those things. I've restarted the speakers and the app several times and in various orders. If I have both speakers on music will will play through thefirst one to connect, turn that speaker off and it immediately switches to the other and continues playing.

 Works fine with my Samsung TabA. The only thing I can think of now is to delete the app and reinstall.

Highlighted
Moderator

Re: Bose Connect party mode stopped working

I'm sorry to hear that, thanks for giving this a go. 

 

Yes, deleting and reinstalling the app is another great next step. Were you able to reboot your connected mobile device also?

 

Following this, check for any available firmware updates for your speaker. This can be done via a computer using a USB and visiting our firmware update website btu.bose.com, which will provide you with full instructions.

 

Let us know how you get on.

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!
Highlighted
Participant
  • 0
  • 9
  • 0
Registered since

Jul 24, 2020

Re: Bose Connect party mode stopped working

Sorry it's taken so long to respond, despite Covid, it's been a busy few weeks.

 

Short of dancing naked around a yew tree at midnight, I think I have now tried everything. Updating, reloading, rebooting; it simply does not work reliably, indeed today after 25 minutes of faffing around, I haven't been able to get party mode to run at all. It got to the point when our family was here that I left the phone and speakers powered and connected for 4 weeks solid. I have tried it on three different tablets and two different 'phones all with exactly the same results.

 

I have renamed the speakers 'Revolve Left', which was my first Revolve bought about 18 months ago and 'Revolve Right' purchased about three months ago. They were thus named on the basis that that's how they connected first time around.

 

There are only two things that are consistent and this appears to be irrespective of which host device I am using. 

1) I can only ever get party mode to work if I connect 'Left' first.

2)'Left' always connects to the left channel and 'Right' to right.

 

Very often, indeed every time today, if I connect one speaker with the other powered off then turn the other on, the sound moves from the first to the second and the first turns itself off, actual full power off. If I then turn the first speaker back on, the reverse occurs, the sound moves back and the second powers off. To add to the confusion, 'Connect' always claims to be connected to the speaker that has just gone off.

 

So I connect 'Left' then 'Party mode'. Click 'Find a device' and power up 'Right'. What happens then is a lottery. Sometimes we get the spinney thing as is searches and it sits there ad-nausium. Sometimes, after a few moments, I get the error screen saying it can't find a device and other times I get the 'Push connect button for one second' screen. What has also started to happen is that 'Left' will announce it is in party mode but the 'Right' will immediately report connection lost and power down.

 

What does happen occasionally is that if I wait for the 'Can't find device' screen before I power up 'Right' then clear the error screen it will actually connect but this is not reliable or repeatable. Any other connection successes appear to be absolutely random and I cannot find any consistent thread for how and when party mode will fire up.

 

The speakers are running V3.0.4 of the firmware, which after 40 years of writing real time software spells disaster anyway. Anything with a Zero is little more than beta release and anything with an even numbered sub release is usually a functional enhancement or correction and it's a good idea to wait for the subsequent odd number release for all of the bugs to be fixed. The android app is 12.0.1, another post beta.

 

For a company with the reputation of Bose, this app is an utter disgrace. When it's working, the sound from the two speakers working in concert is little short of stunning; it's just unusable. I am so disappointed.

Highlighted
Participant
  • 0
  • 9
  • 0
Registered since

Jul 24, 2020

Re: Bose Connect party mode stopped working

Just gets better.....

 

Uninstalled 'Bose Connect', rebooted 'phone and reinstalled the app and we're back to 'sliding' screens.

 

Connect to 'Left' with music playing via Spotify. Music emanates from 'Left' speaker with 'Bose Connect' in Connected mode, i.e. picture of Revolve+ with Bluetooth and Party Mode icons in lower left corner.

Click 'Party Mode'.  

Window now slides off screen to reveal an identical window but the sound now shifts to the 'Right' speaker. This sequence then repeats with the window sliding off the screen and music alternating between left to right several times. We then get a reverse sequence when the window slides back onto the screen and the sound continues to alternate right and left. Each shift takes a fraction of a second but it's enough time to see on the top bar that 'Bose Connect' is showing connection to each speaker alternately.

 

I've tries this several times and it is repeatable except that the number of 'shifts' can vary between 5 and 15 times. The end result, however, is the same; 'Left' connected with the front end screen displayed. (Picture of Revolve+ with Bluetooth and Party Mode icons in lower left corner)

 

Really smacks of a recursive call to a function that is not fully re-entrant AND/OR has flawed call or completion criteria.

 

Is it just me??????????

Highlighted
Participant
  • 0
  • 9
  • 0
Registered since

Jul 24, 2020

Re: Bose Connect party mode stopped working

Hi,

still really struggling. any more suggestions?

Highlighted
Moderator

Re: Bose Connect party mode stopped working

Hey @JWalters1955, sorry to hear that this is still an issue. 

 

Could you please try clearing the pairing list on the speakers. To do this, hold the Bluetooth button for 10 seconds until you hear a 10. Then, delete the speakers from the Bluetooth list on all previously connected devices. 

 

Then, could you try initiating party mode through the following button combination: 

  1. Make sure both speakers are powered on
  2. Make sure a speaker is connected via Bluetooth® to your mobile device
  3. On the speaker connected to your device, press and hold the Bluetooth and Volume + buttons simultaneously
  4. Release the buttons when you hear "Press the Bluetooth and volume down buttons simultaneously on a second Bose device"
  5. On the second speaker, press and hold the Bluetooth and Volume  buttons simultaneously
  6. Release the buttons when the speaker emits a tone. After 10 seconds, you will hear "Party mode" from both speakers simultaneously. Party mode is enabled. You are now able to play audio in unison using your mobile device

Do you have any problems with Party Mode when connecting in this way? 

 

After, could you please test with the Bose Connect app to see if clearing the pairing list has improved the matter.

 

I look forward to hearing back from you.

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 9
  • 0
Registered since

Jul 24, 2020

Re: Bose Connect party mode stopped working

I've already been through most of this except for connecting via the devices themselves. Job for 'morning. I'll get back to you once I've been through it all.

Highlighted
Participant
  • 0
  • 9
  • 0
Registered since

Jul 24, 2020

Re: Bose Connect party mode stopped working

Went throught the whole procedure you outlined 4 times. Start to finish each time.

1) Starting with my original device, "Revolve Left", first everything went according to plan and received the Party Mode message from "Revolve Left". Play some music and sound only comes from the 'left' speaker. 

2) Repeat the whole procedure in case I got something wrong first time. Exact same result.

3) Clear everything down again and start with the newer unit "Revolve Right".  "Revolve Right" announces Party Mode and the other powers down.

4)Repeat again starting with 'Right'. This time it sort of works. Sound from both speakers but mono. Open up Bose Connect and it can see both speakers operating in Party Mode, flick the switch and we have stereo.

 

OK, we got something working but I can't go through that every time and I sure as heck can't explain to my wife, kids or guests the rigmarole they have to go through to get music by the pool.