Highlighted
Participant
  • 4
  • 2
  • 0
Registered since

Feb 4, 2018

Bose Soundlink Color II, not charging, no power, flashing lights

I tried to turn on my Bose Soundlink Color II. First, it turned on and connected to my phone but did not actually play anything, despite being able to control the music on my phone from the speaker (as in play/pause, volume). I turned it off in hopes of fixing the issue and now when I turn it on, while plugged into the wall, the power light flahes amber twice and about 5 seconds later the power, bluetooth, and aux button all flash once at the same time. Then all the lights go dark and nothing happens. This happens every time I try resetting and/or plugging/unplugging the unit from the wall.

 

Things I've tried already:

1. Updating to the latest software (there was an update needed, but it's done now).

2. The hard reset in other threads, ie, holding down the play/pause button for 15 secs, unplugging, then plugging back in and turning on. It only does the strange flashing described above when I try this.

3. Using a different usb charger.

 

I've had this speaker a little more than a month. It previously worked fine. I was playing music on it for a couple hours last weekend. Very frustrated and disappointed.

44 REPLIES 44
Highlighted
Moderator - Retired
  • 0
  • 2527
  • 99
Registered since

Aug 25, 2017

Re: Bose Soundlink Color II, not charging, no power, flashing lights

Hey acatkan!

 

Welcome to the community, I'm glad that you reached out,  It sounds like you've done some extensive troubleshooting, thank you for providing all of that information.  Based off of what you're describing, I think that your best option at this time is to reach out to customer support, you can use this link.  Just select your country and scroll down to where you see "contact us", support will be able to help from there.

 

I hope that you enjoy your day.

 

Take care,

Shiloh - Bose Support   

Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

May 14, 2018

Re: Bose Soundlink Color II, not charging, no power, flashing lights

The same exact thing happens to me.
Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

May 17, 2018

Re: Bose Soundlink Color II, not charging, no power, flashing lights

Same thing happening with me..
Highlighted
Participant
  • 4
  • 2
  • 0
Registered since

Feb 4, 2018

Re: Bose Soundlink Color II, not charging, no power, flashing lights

Just an update on this. I left my speaker plugged in for the better part of a weekend and then left it alone, unplugged for another couple days. Despite no indication that it was charged or charging the entire time it was plugged in, when I tried to turn it on next it worked perfectly fine and has ever since then. I think this speaker just has issues functioning if the battery is completely depleted, not a great problem for a bluetooth speaker. ¯\_(ツ)_/¯

Highlighted
Moderator - Retired
  • 0
  • 2555
  • 114
Registered since

Dec 15, 2016

Re: Bose Soundlink Color II, not charging, no power, flashing lights

Hello @James18 and @Itpmathur,

 

Sorry to hear that! If you have tried all the troubleshooting like resetting your speaker and try another charger, then I would encourage you to reach out to your local Bose Support for further assistance. They will work with you to discuss your service options. Here is a link to get contact information if you needed it.

 

Thank you for writing in, and let us know if there is anything else you need. 

 

 

Take great care,

 

Mohsin

 

 

Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Dec 18, 2018

Bose sound link Colour 2 will turn on for seconds before flashing all lights on and not charging

I only bought this speaker last week and am super happy with how it sounds. today was the first time I let it run out of charge and now all plugging it in to charge will do is bring my speaker back to life for a span of 2-8 seconds before it pulses all of its LED indicators once and then dying and not taking a charge. I have tried holding both the power, and multifunction buttons while connecting and disconnecting from power to no prevail.
Sometimes the voice assist will tell me the battery is low before it dies and other times it will die before it even has a chance to speak.
I'm not quite sure what to do and I'm a little scared my super cool speaker has just died on me!! pls help!? 

Highlighted
Community Manager - Retired
  • 0
  • 3053
  • 125
Registered since

Mar 15, 2018

Re: Bose sound link Colour 2 will turn on for seconds before flashing all lights on and not charging

Hi HaleDunt,

 

Thanks for posting on the Community!  Sorry to hear about the power issues, but would be happy to help!

 

  • Can you try and connect the speaker to a computer with the USB cable and navigate to btu.bose.com?
  • This is an updater we have online and would like to see if there is an update available for the system.  
  • If this doesn't work, we can try a different type of reset:
    • Connect the speaker to a power outlet
    • Reconnect power 
    • Release the Multi-function button
    • While continuing to hold the Multi-function button, unplug the speaker from power
    • Press and hold the Multi-function button for 10 seconds

Let us know how it goes!

 

Warm Regards,

Tony A - Community Support 

 

 

Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Dec 19, 2018

Re: Bose sound link Colour 2 will turn on for seconds before flashing all lights on and not charging

My speaker has these exact same symptoms - except that it has now started making a two-tone beep after the orange power light initially flashes, and before the 3 - LED flash. Bose support say I should return it, but am going to try retailer first.

Tony A - those instructions seem to be out of sequence?

Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Dec 31, 2018

Re: Bose sound link Colour 2 will turn on for seconds before flashing all lights on and not charging

I had the same problem. I just used a different usb charger and cable after trying everything else and now it works fine. every few months when I accidentally let it run all the way down, i have to do a hard reset on it but this time it just wouldn't take and i got all the led lights and stuff.

works fine now. try a different cable / square.