Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Jun 16, 2020

Bose Soundlink Colour 2 is dead again

Bose product name - Soundlink Colour 2

Country of purchase - Japan

Issue - It's not turning on (with/without) plugged in. Its charged for the whole weekend using Ac charger and laptop but still it did not turn on. When plugged in it initially beeps a red light then goes off.

I have updated the software from btu.bose.com but didn't help.

Further, I have kept the device connected and then pressed the multifunction button for 15-20 sec thereby removing the device from the charging point and slowly releasing the multifunction button. Then it beeps red light followed by white light from the Bluetooth area followed by all 3 lights flash once and it says connected to iPhone etc but then it dies down. 

 

Can someone help? This device has given me so much problem in the last 2 years. Within 3 months it had issue which made the device replaced, then again within the next 1 year it had issues again replaced now its third time. I do not understand how a company like Bose sells such a malfunctioned device. 

1 REPLY 1
Highlighted
Moderator

Re: Bose Soundlink Colour 2 is dead again

Hi there @chandrikachanda,

 

Thank you for reaching out to us and welcome! 

 

Thank you for trying all that great troubleshooting, this is all that we would normally recommend. 

As the troubleshooting has been unsuccessful at this time, I would recommend reaching out to your local technical support team for assistance. Click the LINK HERE, select your country and scroll down to 'Contact Us'. One of the team will be more than happy to assist you!

 

If there is anything else we can do for you, please reach out to us again!  

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!