Participant
  • 0
  • 2
  • 0
Registered since

Mar 30, 2020

Bose sound link revolve

My sound link revolve remained idle for sometime. Now, but I plug it in the red light flashes continually but does not connect to anything. When I unplug it, no light goes on. How do I resuscitate the speaker?

5 REPLIES 5
Expert
  • 362
  • 1696
  • 61
Registered since

Jun 15, 2018

Re: Bose sound link revolve

@dpfitzg1I just posted twice in posts here a possible solution.

Participant
  • 0
  • 2
  • 0
Registered since

Mar 30, 2020

Re: Bose sound link revolve

I can’t find the two responses. Sorry, I’ve never used this procedure before. Don’t know where to look for the responses.

Moderator

Re: Bose sound link revolve

Hi there, 

 

Thank you for your post. 

 

I'm sorry to hear of the issues you are experiencing with your SoundLink Revolve. I'll be more than happy to assist you!

 

I would recommend making sure your Revolve is up to date with the most recent firmware. You can do this by clicking the LINK HERE on a laptop or PC and following the on-screen instructions. 

 

Let me know how it goes!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Participant
  • 0
  • 2
  • 0
Registered since

May 27, 2020

Re: Bose sound link revolve

Hi There,

I have the same issue, I updated the firmware but the issue remains.

 

 

Moderator

Re: Bose sound link revolve

Hello Marvin, 

 

Thanks for posting and welcome to the Bose Community. Sorry to hear that you are also experiencing this issue. 

 

I would highly recommend performing a reset on your speaker by following these steps below:

  • Disconnect the power cord
  • Power on your product using battery power
  • Press and hold the Multi-function (•○•) button for 10 seconds until the product lights glow.

If the issue still persists after this, I would suggest charging the speaker via a few different outlets to see if the same issue occurs.

 

We look forward to hearing back from you with the result of these steps. 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!