• 0
  • 1
  • 0
Registered since

Jan 14, 2020

Bose speaker wont charge

I've tried to hard reset. Ship setting. And factory reset, but my soundlink mini 2 still wont charge. It has a red flashing light that wont go away. I've tried using different cables and plugs. Also I've tried updating my firmware. Any ideas??


Thanks in advance.


Re: Bose speaker wont charge

Hi CameronE, 


Welcome to the community, thanks for reaching out. I am very sorry to hear of this experience you are having with your SoundLink Mini II. We appreciate you looking into troubleshooting this, these were great first steps. 


Regrettably you have attempted all the troubleshooting in which we would suggest. Therefore, to continue I would recommend that you reach out to your local support team as a red flashing LED would indicate a battery error of your speaker. Our local support team can be contacted via clicking this link and selecting your region, this will redirect you to our website. Please scroll to the bottom of the website and there you will find a 'Contact Us' tab, this will provide you with all the relevant contact information for your country. An agent here will happily get this resolved for you. 


Kind regards,

Tegan M - Community Support

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!