Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Aug 2, 2020

Boss Soundlink Revolve + disconnecting

I’ve had my Bose soundlink revolve for a couple of years with no problems. Yesterday the speaker disconnected from my iPhone. When I try and pair it again it does connect but doesn’t say that my device is connected. Then when the speaker is switched off, when I turn it back on-it doesn’t say that it is connected to my device And I have to connect it again. I’ve tried clearing the Bluetooth list but it doesn’t work. It’s the same for my husbands iPhone too? Any ideas before this gets sent in for repair???

 

 Thanks 

 

jayne

1 REPLY 1
Highlighted
Expert
  • 340
  • 1513
  • 46
Registered since

Jun 15, 2018

Re: Boss Soundlink Revolve + disconnecting

@Jayne314Well it's not a 'global' issue since I have an iphone 7+ and two revolves and I am not having the issue you described with either.  Here is something to try - it may or may not work but worth a shot....

1. Make sure your iPhone is on iOS 13.6 (current version)

2. Go to Bluetooth in the iPhone and remove/delete all entries for any Bose products - headphones, ear buds, speakers, etc.

3. Turn off Bluetooth on the iphone

4. Depress the multifunction key on the Revolve until all the lights blink

5. Turn on the Revolve with the top button.  You may have to do this multiple times and it may need to be plugged in

6. Turn off the Revolve with the top button.

7.  Reset the Revolve by holding down the multifunction key for 10 or more seconds.

8. Pick English as instructed.

9. When the Revolve says ready to pair, turn on bluetooth on the iphone and pick the Revolve from the bottom of the window.

10. (optional) Using Bose Connect make sure the firmware in the Revolve says 3.0.4 (the latest version).  If it does not, it is your 'call' whether to update the firmware as that may or may not make a difference.

If your problem continues even after the above, you would need to do additional troubleshooting with Bose.  My process above is a modfied version of what they recommend.  I have experienced and heard here that sometimes when the Bose process fails mine works (sometimes it needs to be done multiple times).

Again remember this is something likely specific to you as others like me have not experienced it.

P.S. - there is an outside 'chance' the issue may be specific to the model of the iphone you have so I would if you have not already done tried the above process on both a newer iphone model (say X or 11) and an older one (say 6,7, or 8).