dustoff_pilot
Participant
  • 0
  • 3
  • 0
Registered since

Aug 7, 2020

Rename SoundLink Revolve speaker in Bose Connect app

When trying to rename my Bose SoundLink Revolve speaker within the Bose Connect app, there are no options, selections or menus to choose from that allows me to make such a change.  I have a total of three (3) Revolve speakers in the household.  The first one was purchased in 2017 and was renamed via the app without issue.  The 2nd and 3rd units however were purchased over the past year, and the Connect App does not appear to have the same "renaming" functionality interface with the speakers anymore.  I am running v. 12.0.1 of the Connect app (most up to date version on the App Store) on an iPhone 8, and the firmware has been updated on all speaker devices.

 

The frustration of not knowing which "Bose Revolve SoundLink" when pairing devices is incredibly irritating.  Thanks in advance for helpful resolution.

2 REPLIES 2
joelirwin
Expert
  • 374
  • 1763
  • 66
Registered since

Jun 15, 2018

Re: Rename SoundLink Revolve speaker in Bose Connect app

@dustoff_pilotI have two Revolve's and I have an iphone 7+ using Bose Connect app (version 12.0.1) and I have had no problems renaming my Revolves.  Here is a way to do it:

1. Start the Connect app

2. Turn on the Revolve and let it connect to the iPhone

3. Tap the wheel in the upper right hand corner

4. Tap the first entry on top that says "Name"

5. Hit the "X" on the right below "Nickname It" to clear it out

6. Type in your new Name

7. Tap the black "continue"

8. Tape the "X" in the upper right hand corner

9. The new name should be in the top and center

10. Shut down the Connect app by swiping up.

 

dustoff_pilot
Participant
  • 0
  • 3
  • 0
Registered since

Aug 7, 2020

Re: Rename SoundLink Revolve speaker in Bose Connect app

Thanks for that info!  That process you describe still doesn’t work on my iPhone 8 (speakers will not pair through the connect app to provide that functionality), but it does work on my iPad mini.  Are there known issues with Connect App functionality on iPhone 8 models (currently running iOS 13.6)?