• 0
  • 1
  • 0
Registered since

Aug 4, 2020

Resolve appears dead

Resolve got caught in some rain last yesterday. Worked fine after this. It was at 50% so attempted to charge later. No go. 

Just before heading to bed I noticed orange charge light was on along with the Bluetooth and other selector (Not plugged in). Would not power off. Today it’s totally dead and won’t charge, not even the light will come on. I’ve tried multiple cables and chargers, mains and USB on a laptop and tried testes as per advice here and elsewhere. Also tried to update software but laptop won’t connect and Bose app doesn’t find the Resolve. I’m out of ideas!

Any ideas or is it time to lodge a service request?


Re: Resolve appears dead

Hi DaleF, 


Welcome to the Community! We're sorry to hear about your SoundLink Revolve being caught in the rain.


As you have already attempted to charge the speaker via other outlets and with other cables and are still not able to get the speaker to perform correctly. I'd recommend reaching out to us via this link here


Due to the laptop not being able to see the speaker when attempting the manual update method, this would indicate to me that the speaker needs to be serviced. 


Please do let us know if you have any issues reaching the support team in your region. 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!