• 0
  • 1
  • 0
Registered since

Jun 26, 2020

Soundlink 2 not turning on or resetting

So i bought a soundlink 2 about 2 weeks ago on vacation and it worked great. We returnee home and used it out on the boat for the day and now it wont charge, turn on, or reboot. When i plug it into to charge the power button flashes amber twice then a few seconds after that, the power, bluetooth, and the aux light all blink simultaneously one time and thats it. It wont charge or turn on even after i tried the multufunction button reboot. 


Re: Soundlink 2 not turning on or resetting

Hi JdKeogh,


Welcome to the community! 


I'm sorry to hear you are having trouble with your new speaker but I'm sure we can get this back up and running together.


So I can provide you with the most accurate information can you let me know which model of speaker you have? We have a couple of SoundLink speakers that have a version 2, so knowing exactly which one you have would be really helpful! If you are unsure, you can double-check this with our Product Identifier.


I look forward to hearing from you!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!