Highlighted
Participant
  • 0
  • 2
  • 1
Registered since

Jun 29, 2020

Soundlink Mini II - Red LED on Permanently and won't turn on/charge

Hi everyone,

 

I think I probably know the answer to this question but here goes anyway. I've not attended my office for over 3 months due to the COVID19 restrictions but went back today and I noticed the LED on my Soundlink Mini 2 was on permanently (not flashing) - I've tried charging it on and off the base, resetting it using the "hold the multi-function button for 10 seconds, remove power etc." option and also holding the power button for 10 seconds but nothing changes - When I do reset it and disconnect the power it flashed (very briefly) amber and gives half a beep.

 

Any suggestions? I'm guessing the battery is knackered and a victim of Lockdown!!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Participant
  • 0
  • 2
  • 1
Registered since

Jun 29, 2020

Re: Soundlink Mini II - Red LED on Permanently and won't turn on/charge

Author Accepted Answer selected by DarrenWilliams

Hi Jesse,

 

Thanks for the reply (albeit they're not headphones?!). I've just sent my BT speaker off to you guys for repair so looking forward to it coming back in full working order.

 

Darren 

View solution in original post

4 REPLIES 4
Highlighted
Moderator

Re: Soundlink Mini II - Red LED on Permanently and won't turn on/charge

Hi DarrenWilliams,

 

Thank you for your post and welcome to the Community. 

 

I'm sorry to hear of the issues you seem to be having with your SoundLink Mini II. I'll be more than happy to help you!

 

I would recommend updating the firmware of the headphones. You can do this by following the instructions HERE

 

Let me know how you get on! 

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!
Highlighted
Participant
  • 0
  • 2
  • 1
Registered since

Jun 29, 2020

Re: Soundlink Mini II - Red LED on Permanently and won't turn on/charge

Author Accepted Answer selected by DarrenWilliams

Hi Jesse,

 

Thanks for the reply (albeit they're not headphones?!). I've just sent my BT speaker off to you guys for repair so looking forward to it coming back in full working order.

 

Darren 

View solution in original post

Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Jul 16, 2020

Re: Soundlink Mini II - Red LED on Permanently and won't turn on/charge

I have the same issue, red light on constantly after being left without power for only 3 days and now wont charge. I have tried everything suggested, reset, change ,cable, AC , firmware etc. It make the charge noise when its connected, the update recognises it and it's on 1.1.4 but wont reinstall the firmware (via the A D V Up Down option) as the battery level is apparently too low.

 

I have left it in the AC charger for days and still nothing.

 

Where do in go from here?

Highlighted
Moderator

Re: Soundlink Mini II - Red LED on Permanently and won't turn on/charge

Hi RonanO,

 

If the troubleshooting you have been trying so far has not done the trick,  I would recommend getting in touch with your local support team, to look at booking your speaker for a service as well. You can find the contact information at this link, by selecting your country/region and then the 'Contact Us' option at the bottom of the page.

 

I hope this helps!

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!