Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Sep 12, 2020

Soundock Loose Connection - On/Off while being plugged in

Auckland, New Zealand

SoundDock Portable digital music system (2007 - 2014)

 

Been a great sound system since 2013. 
It use to work when plug adaptor was connected & battery would never charge which was fine as it became a sound system in a garage. 

Now when it’s plugged it the green light flicks on then off continuously whilst it is plugged in accompanied by the sounds of it being turned on & off. There is no movement of the plug adaptor, using of the remote or anything. 

I know the battery needs replacing (as it has served me greatly over the years) but if I get a new one - will that even be charged with my current plug adapter issue?

1 REPLY 1
Moderator

Re: Soundock Loose Connection - On/Off while being plugged in

Hi kelsieann,

 

Welcome to the Community!
 

From how you are describing this it does sound like there is an issue with the power reaching the speaker correctly. Have you tried plugging the speaker into any other power outlets? It would be worth doing so to make sure the issue isn't being caused by the outlet it is plugged into.

 

If you do see the same behavior with the speaker turning itself off and on with multiple outlets, you will need a new power supply for the system. I'd recommend reaching out to your local support team to discuss the service options for the speaker. That way you'll be able to see what can be done about the battery as well as the power supply. 

 

As you are in New Zealand, you can find the contact information for your local support team HERE.

 

I hope this helps!

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!