Kyle2
Participant
  • 0
  • 3
  • 0
Registered since

May 13, 2021

Phone Alerts don't respect Do Not Disturb exceptions

Bose product name: Sleepbuds

 

Country: United States

 

Firmware Version: 11.15.1.0

 

App Version: 3.0.8 Build Version: 379


What devices were you using that were affected and what version are they on (e.g. Samsung Galaxy S9 on Android 11, iPhone X on iOS14, etc.):   Google Pixel 4a on Android 11 (May 5, 2021 security update) (And previously Google Pixel 2/3a on Android 9, 10, and 11)

 

Detailed description of the issue and steps to reproduce: When I enable `Do Not Disturb` on my Pixel 4a, I do not receive phone alerts on my device. The moment I disable `Do Not Disturb` , I receive alerts. _This makes sense_ .
However, I am expecting it to follow my `Do Not Disturb`  caller exceptions like my starred contacts. If a contact is starred, they can bypass my `Do Not Disturb` phone settings and ring my phone. But even though my phone is ringing from a starred contact, because `Do Not Disturb` is turned on my sleepbuds don't alert me.

 

Back when this feature was first released, the release notes state:
This update introduces "phone call alerts." This feature allows users to decide whether or not to receive an in-bud alert when a connected mobile device receives an incoming call. The alerts played in the Sleepbuds follow the device's “do not disturb” settings which can be set to allow all calls or limit calls to the device’s "Favorites".
 

Source: https://community.bose.com/t5/Wellness-Archive/Bose-Sleep-App-2-1-0-and-Sleepbud-Firmware-7-0-0-0/td...

 

The important line is "or limit calls to the device’s "Favorites"". I would have expected my starred/favorite contacts to still alert me on my sleepbuds just like they are on my phone. I use this functionality to be alerted of calls from my paging system for any issues at work. I would greatly appreciate if it could be used without needing to turn off `Do Not Disturb` for my entire phone. 

 

Is this a bug, or has the functionality been removed around DnD exceptions?

 

When did you start to experience the issue? Did it work correctly previously?:   I've always experienced this issue. Both on my old phones (Pixel 2, Pixel 3a), and on the original Bose Sleepbuds (version 1).
Any troubleshooting steps you took:  

  • I granted the application all available permissions (like contacts)
  • Rebooted the phone
  • Reset the app
  • Toggled Do No Disturb. 
  • Added/removed users to the "starred" contacts.

 

 

 

 

 

3 REPLIES 3
Kyle2
Participant
  • 0
  • 3
  • 0
Registered since

May 13, 2021

Re: Phone Alerts don't respect Do Not Disturb exceptions

Bump.

Vicky_W
Moderator

Re: Phone Alerts don't respect Do Not Disturb exceptions

Hello Kyle2, 

 

Thank you for posting and welcome to the community forums. 

 

The 'Do Not Disturb' feature on the Sleepbuds II does not take into account any exceptions on the 'Do Not Disturb' feature on Android. I am happy to raise this as a possible feature request but I am unaware of any plans to add this as a feature at this time. 

 

I hope this explains things more for you. 

 

 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Kyle2
Participant
  • 0
  • 3
  • 0
Registered since

May 13, 2021

Re: Phone Alerts don't respect Do Not Disturb exceptions

Thanks Vicky,

 

I would appreciate if you could raise this as a possible feature request. I noticed it was part of the original release notes for the feature and it was something I was very excited for.