Highlighted
rtbanffer
Quiet Contributor
  • 0
  • 8
  • 0
Registered since

Jan 14, 2019

Cannot add Alexa to my Soundbar 700 ( fails at logging in at id.api.bose.io )

Dear forums,

 

I can't seem to add Alexa though the Bose Music app, after signing in through Amazon in the app, it redirects me a couple of times and displays an empty page on the following URL: id.api.bose.io

I checked the Alexa app, and the soundbar was added, but the Bose Music app still initialises the Alexa setup.

 

Is there anything i can do to make this work?

15 REPLIES 15
Moderator

Re: Cannot add Alexa to my Soundbar 700 ( fails at logging in at id.api.bose.io )

Hi rtbanffer,

 

Thanks for the post, and welcome to the community!

 

What kind of mobile device are you using to setup the product?  If you aren't already, could you try using an iOS device like an iPhone or iPad?

 

Do the Alexa commands function correctly?  Are you also about to use the Bose Music app without issue?

 

Let us know so we can get this resolved for you.

 

Best Regards,

Brandon - Community Support

rtbanffer
Quiet Contributor
  • 0
  • 8
  • 0
Registered since

Jan 14, 2019

Re: Cannot add Alexa to my Soundbar 700 ( fails at logging in at id.api.bose.io )

Hi,

 

Thanks for replying 🙂

I'm using an iPhone 7 Plus running 12.1.3 ( 16D5039a ).

The problem is that i can't add Alexa in the app, as it hangs during the setup when authenticating with the bose Api. This is right after you log in to your amazon account in the setup.

I haven't got Alexa to work at all, i can see the soundbar being added in the Alexa app though but it seems that the registration doesn't work on the Bose side.

 

I'd really love it if i could get Alexa to work, one of the reasons i bought this soundbar.

duncan1873
Friendly Fanatic
  • 6
  • 17
  • 0
Registered since

May 9, 2017

Re: Cannot add Alexa to my Soundbar 700 ( fails at logging in at id.api.bose.io )

Hi there,

If you have connected the sound bar to your home network with an Ethernet cable switch off your sound bar & disconnect the Ethernet cable. Switch the power back on & connect via WiFi via the app on the phone. That worked for me when Alexa disappeared from my sound bar 700. Good luck.
rtbanffer
Quiet Contributor
  • 0
  • 8
  • 0
Registered since

Jan 14, 2019

Re: Cannot add Alexa to my Soundbar 700 ( fails at logging in at id.api.bose.io )

Hey,

 

I've tried your approach, but i still can't complete the Alexa setup since it hangs during the id.api.bose.io stage.

@Brandon_M There really seems to be something wrong when authenticating with the bose api, can you ask the development team to check the logs for my particular situation to see where the API fails?

Moderator

Re: Cannot add Alexa to my Soundbar 700 ( fails at logging in at id.api.bose.io )

Hi again,

 

Thanks for the post.

 

We can take a look at the log files, however there's a bit more troubleshooting i'd like you to try.

 

Are you able to download a different browser (like Chrome or Firefox) and set it as your default browser, then try Alexa setup again?  There may be an issue with Safari not properly functioning and logging users in.

 

Let me know what happens, and we can proceed from there.

 

Best,

Brandon

rtbanffer
Quiet Contributor
  • 0
  • 8
  • 0
Registered since

Jan 14, 2019

Re: Cannot add Alexa to my Soundbar 700 ( fails at logging in at id.api.bose.io )

Hi Brandon,

 

Installing another browser is possible, but the Bose Music App uses a built in safari webkit webview so it doesn't matter if you install another browser, so that has no effect. I've tried and it did not prompt me to use Chrome during the Alexa setup in the Bose Music App.

duncan1873
Friendly Fanatic
  • 6
  • 17
  • 0
Registered since

May 9, 2017

Re: Cannot add Alexa to my Soundbar 700 ( fails at logging in at id.api.bose.io )

Are you using Ethernet or WiFi? I had problems via Ethernet, Alexa was unresponsive & when I hook up with WiFi it worked fine.

Good luck,

Duncan
rtbanffer
Quiet Contributor
  • 0
  • 8
  • 0
Registered since

Jan 14, 2019

Re: Cannot add Alexa to my Soundbar 700 ( fails at logging in at id.api.bose.io )

I've tried both, same results however...

rtbanffer
Quiet Contributor
  • 0
  • 8
  • 0
Registered since

Jan 14, 2019

Re: Cannot add Alexa to my Soundbar 700 ( fails at logging in at id.api.bose.io )

@Brandon_M Is there any way i can send you logs, so a development team can take a look at it and make sure it's not an api problem?

I'd like to know if it's a problem with my Bose account, Amazon account or if it's an bug in the Bose Music App.