DanEllisUK
Vocal Volunteer
  • 32
  • 101
  • 2
Registered since

Oct 14, 2018

“Product help” button in Bose music app does not work (404 - page not found)

I was trying to reconnect the Bose Soundbar 700 using WiFi instead of Ethernet.

The discovery did not find any products and so the app displayed a Product Help button.

 

The button takes you to http://worldwide.bose.com/support/smart_speaker_setup

 

But the server desponds with this error:

 

{"timestamp":1540138909785,"status":404,"error":"Not Found","exception":"com.bose.pulsar.server.rule.exceptions.RuleNotFoundException","message":"No Rule found","path":"/proxy/support/smart_speaker_setup"}

 

7 REPLIES 7
Highlighted
Community Manager

Re: “Product help” button in Bose music app does not work (404 - page not found)

Hi DanEllisUK

 

Thanks for writing in!

 

I tried to replicate this on my side but was unsuccessful.  If you try again, does the same error come up?

 

Let us know!

 

Warm Regards,

Tony A - Community Support 

 

DanEllisUK
Vocal Volunteer
  • 32
  • 101
  • 2
Registered since

Oct 14, 2018

Re: “Product help” button in Bose music app does not work (404 - page not found)

The product help is still going to that same URL, and that URL is still responding with an error.

This is on the IOS app (iPad Pro, IOS12).  I’ve just tried the Android app, and that works fine.

Community Manager

Re: “Product help” button in Bose music app does not work (404 - page not found)

Hi DanEllisUK

 

Thanks for the update!  That's certainly odd as I tried the same steps and it appears to be working fine (iPhone X iOS 12.0.1).  The product help button should bring you to a browser page that shows the 3 Smart Home speakers.  From here it allows you click the speakers for detailed setup instructions.  Is the 404 error coming up right after selecting product help or after selecting one of the speakers?  

 

Warm Regards,

Tony A 

DanEllisUK
Vocal Volunteer
  • 32
  • 101
  • 2
Registered since

Oct 14, 2018

Re: “Product help” button in Bose music app does not work (404 - page not found)

It is the first page with the Product Help button as shown here.

I have rebooted the iPad and also updated to 12.0.1, still the same issue.

I’ve also tested on a second iPad Pro, with the same result.

4E48A79C-C6F3-474E-A2B5-5D7C46DA7070.png

Community Manager

Re: “Product help” button in Bose music app does not work (404 - page not found)

Hi DanEllisUK

 

This is very strange, as I tested this with about 4-5 different iOS devices on different iOS versions and am unable to recreate the issue.  If you take the URL that you provided earlier and paste it into a few different browsers on the iPhone (Safari/Chrome/Etc) does the error come up?  Also, has a reboot to the network happened yet?

 

Warm Regards,

Tony A 

DanEllisUK
Vocal Volunteer
  • 32
  • 101
  • 2
Registered since

Oct 14, 2018

Re: “Product help” button in Bose music app does not work (404 - page not found)

Lets compare DNS results.   When I run nslookup worldwide.bose.com.

 

C:\>nslookup worldwide.bose.com
Server:  router
Address:  192.168.10.1

Non-authoritative answer:
Name:    worldwide.bose.com
Addresses:  13.32.123.90
          13.32.123.12
          13.32.123.148
          13.32.123.81

 

Another test, returns different addresses:-

 

 

C:\>nslookup worldwide.bose.com
Server:  router
Address:  192.168.10.1

Non-authoritative answer:
Name:    worldwide.bose.com
Addresses:  54.230.8.65
          54.230.8.244
          54.230.8.251
          54.230.8.86

 

Also try using Google DNS directly:-

 

 

C:\>nslookup
Default Server:  router
Address:  192.168.10.1

> server 8.8.8.8
Default Server:  google-public-dns-a.google.com
Address:  8.8.8.8

> worldwide.bose.com
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Non-authoritative answer:
Name:    worldwide.bose.com
Addresses:  13.32.123.148
          13.32.123.81
          13.32.123.12
          13.32.123.90

 

These addresses are all for cloudfront.net, so you may get different addresses, but they should all be for cloudfront.

 

I have manually queried all these addresses from the UK, and they all return 404 responses such as this:-

 

 

HTTP/1.1 404 Not Found
Content-Type: application/json;charset=UTF-8
Content-Length: 205
Connection: keep-alive
Cache-Control: no-cache, no-store, max-age=0, must-revalidate
Date: Tue, 23 Oct 2018 20:39:33 GMT
Expires: 0
nebula_service: pulsar
Pragma: no-cache
Server: nginx/1.7.10
X-Application-Context: pulsar:prod02:7431
X-Content-Type-Options: nosniff
X-Frame-Options: DENY
X-XSS-Protection: 1; mode=block
X-Cache: Error from cloudfront
Via: 1.1 2e506e9ca9f917cce65011567b65d797.cloudfront.net (CloudFront)
X-Amz-Cf-Id: 6nYwPmCCh1R5KZFByiAOtjJETDmbYenYgjGD-R0cVxXYZCI2aJJ54w==

{"timestamp":1540327173985,"status":404,"error":"Not Found","exception":"com.bose.pulsar.server.rule.exceptions.RuleNotFoundException","message":"No Rule found","path":"/proxy/support/smart_speaker_setup"}

 

I have tried this from a few different offices around the world and I find they all receive the same error.

 

I have had a french server respond with an appropriate redirect.  These are the headers the repsponse included:-

 

 

HTTP/1.1 301 Moved Permanently
Content-Length: 0
Connection: keep-alive
Access-Control-Allow-Methods: GET, POST, PUT, DELETE, OPTIONS
Access-Control-Allow-Origin: *
Cache-Control: no-cache, no-store, max-age=0, must-revalidate
Date: Tue, 23 Oct 2018 20:19:27 GMT
Expires: 0
Location: https://www.bose.fr/fr_fr/support/smart_speaker_setup.html
Nebula-Response-Details: reason: Exact match; rule-id: 0c9a043c-760a-45bf-84e4-e0509d0e2416
nebula_service: pulsar
Pragma: no-cache
Server: nginx/1.7.10
X-Application-Context: pulsar:prod02:9533
X-Content-Type-Options: nosniff
X-Frame-Options: DENY
X-XSS-Protection: 1; mode=block
Age: 1749
X-Cache: Hit from cloudfront
Via: 1.1 b44f106cb108901846bfcc9a6508c901.cloudfront.net (CloudFront)
X-Amz-Cf-Id: zJ7gpTNH_mhdJ_YlFLWvwDVYBZKE9k7UW_uov_qTg4igzIH49mpl5Q==

 

So this response redirected the browser to an appropriate product page (french url)

 

https://www.bose.fr/fr_fr/support/smart_speaker_setup.html

 

So it appears you may have a problem with your cloud front end configuration at cloudfront.net.

Community Manager

Re: “Product help” button in Bose music app does not work (404 - page not found)

Hi DanEllisUK

 

Thanks for the extensive troubleshooting.  I have escalated this to our development team, and was able to reproduce the issue in the UK as well.  Please standby as we look into this and get it resolved.

 

Thank you!

Tony A