Enthusiast
  • 37
  • 121
  • 1
Registered since

Feb 2, 2019

700 soundbar remote and xfinity X1

Has any one figured out how to get the 700 remote work with Comcast’s Xfinity X1 boxes? I’ve tried the setup in the Bose app numerous times. I’ve tried using Comcast, Xfinity as the brand and the codes don’t work. Then I tried the advanced settings and added the model number. It recognizes it and all looks fine but it ultimately doesn’t work. This seems odd since Comcast I’d one of the biggest cable providers around. 

2 REPLIES 2
Participant
  • 0
  • 1
  • 0
Registered since

Dec 9, 2019

Re: 700 soundbar remote and xfinity X1

I have the same problem, would like to use the remote for all controllable devices I have.

Participant
  • 0
  • 2
  • 0
Registered since

Nov 25, 2020

Re: 700 soundbar remote and xfinity X1

Yes, I got it to work, at least 99% of the functionality. So I wish I could tell you the exact steps I did, but I spent at least 8 hours trying different configurations with the Bose App before I got it to work and didn't write down the steps. Here's what I know: 

1. Reset the TV back to factory settings

2. When through it all but disabled Samba software - I read some place to do that and it started working. 

3. Setup Xfinity Cable box on the TV

4. Reset the Bose app and reinstalled Xfinity cable box

After doing all that the TV remote now can use the Xfinity cable box. I do not like how all the buttons function e.g if I'm in the Xfinity menu and select "Back" instead of exiting to the channel I'm watching, it goes back to the previous channel. The other buttons don't function exactly how you would expect either, however; the Bose remote buttons do work as advertised BUT when I first turn the TV on, the Bose remote is dead and will not function the Xfinity box UNTIL I press one button on the TV remote to call up an Xfinity function. Then the bose remote works perfectly, but I have to use the programmed TV remote first to "Wake" it up. Weird??? 

 

P.S. I have the Sony A8H OLED TV.