This widget could not be displayed.
Highlighted
Participant
  • 0
  • 2
  • 0
Registered since

Jun 27, 2020

Acoustimass 300 Stopped working after 1yr

My Bose Acoustimass 300 just stopped working after 1yr from the day of purchase.I tried to troubleshoot like unplugging from power and reconnecting, changed the power cable and nothing worked. the status led light at the back of the unit does not show any light. Seems like this is a common problem for AM300’s. I feel that it is unfair that a expensive unit died couple of days after the warranty expired. is there any chance that I can get my unit fixed?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Expert
  • 167
  • 838
  • 83
Registered since

Dec 4, 2016

Re: Acoustimass 300 Stopped working after 1yr and 5 days

Author Accepted Answer selected by ugin

Call through to the Bose call center and see what they say.  They are normally pretty good about these situations as long as you have proof of purchase

View solution in original post

2 REPLIES 2
Highlighted
Expert
  • 167
  • 838
  • 83
Registered since

Dec 4, 2016

Re: Acoustimass 300 Stopped working after 1yr and 5 days

Author Accepted Answer selected by ugin

Call through to the Bose call center and see what they say.  They are normally pretty good about these situations as long as you have proof of purchase

View solution in original post

Highlighted
Participant
  • 0
  • 2
  • 0
Registered since

Jun 27, 2020

Re: Acoustimass 300 Stopped working after 1yr and 5 days

Went to the Electronic Store  where I purchased and they replaced the unit.