Highlighted
Audible Advocate
  • 2
  • 7
  • 0
Registered since

Apr 4, 2020

Home Speaker 500 - Alexa broken: Commands only working for first song played

Hi all

I have a Home Speaker 500 and use it with Alexa & Spotify. Whenever I start ("Alexa, play spotify"), I can use commands such as ("Alexa, next song"). But once I have played more than one full song from beginning to end, Alexa does not accept my commands anymore ("Alexa, next stong" - Alexa responds: "I can't skip to the next song". Same with previous song / replay song etc.). The only fix which gets the commands to work again is restarting the home speaker. But then again, commands only work until one full song is played. (The only Alexa voice commands that continue to work throughout are the volume controls and turning on / off.)

 

My speakers are properly linked with Alexa and Spotify. I am based in Germany and use Alexa in English. I run the latest firmware.

 

Is this a known issue? Are there other people who have encountered this? Please help me resolve this, because this is not a smart speaker right now. I could live with this if there were at least next song / previous song buttons on the device but when I am required to use voice commands they do need to work.

 

Many thanks in advance!

12 REPLIES 12
Highlighted
Wistful Whisperer
  • 0
  • 2
  • 0
Registered since

Apr 5, 2020

Re: Home Speaker 500 - Alexa broken: Commands only working for first song played

Hi, I have exactly the same problem with Alexa and Spotify in spanish: Alexa tell me that it's not possible skip to next song, etc...
I noticed of this issue some months ago, and I was expecting that a new firmware version solve this, but after some updates, the problem remain present.
Could "Bose" help us ? Probably there are more users with same problem.
Thanks in advance

Highlighted
Community Manager

Re: Home Speaker 500 - Alexa broken: Commands only working for first song played

Hey,

 

Sorry to hear that you're both experiencing difficulties with Alexa. It's interesting to hear that you're both using them in different regions, or varying languages. Can you confirm - do you both have a paid-for premium subscription to the service? Additionally, is Spotify set to the default music service within the Alexa app?

 

Additionally, do you have any other Alexa-enabled devices in your home? Can you test the same playback with the same services, do they operate as intended? 

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started.
Highlighted
Audible Advocate
  • 2
  • 7
  • 0
Registered since

Apr 4, 2020

Re: Home Speaker 500 - Alexa broken: Commands only working for first song played

Thank you the reply. To address your questions:

- Yes, I use the paid version of Spotify

- Yes, Spotify is set as default music app within Alexa

- I have no other Alexa-enabled devices to check this service with besides the Home Speaker 500

 

Any help with troubleshooting would be much appreciated, especially as it seems like I am not the only one with this issue.

Highlighted
Community Manager

Re: Home Speaker 500 - Alexa broken: Commands only working for first song played

@User-f78eb Let's try removing the Alexa skill, and the Spotify connection completely, on both the Bose Music application and the Amazon Alexa app. 


To do this on the Bose Music app, select your profile icon in the top-right of the screen > Manage Music Services > Spotify > Remove Account. Then, return to the main page of the Bose Music app. Select your speaker > Settings > Voice Assistant > Alexa > Remove Account.

 

Then, head over to the Amazon Alexa app. Tap the menu button in the top-left of the screen (three horizontal bars) > Settings > Music > Spotify > Unlink Account. 

 

Then, re-add Spotify back to your Bose Music account. Open app > Profile icon in top right > Manage Music Services.

 

Re-enable Alexa - Bose Music app main page > Select speaker > Settings > Voice Assistant.

 

Re-add Spotify within the Alexa app, and set back as the "Default Music Library". Finally, test the service again.

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started.
Highlighted
Audible Advocate
  • 2
  • 7
  • 0
Registered since

Apr 4, 2020

Re: Home Speaker 500 - Alexa broken: Commands only working for first song played

Thank you Andy for the precise instructions - I followed these exactly. Unfortunately, the same issues still persist. The only difference is that Alexa now responds in German by default.

 

Any alternative suggestions how the problems can be fixed would be much appreciated!

Highlighted
Moderator

Re: Home Speaker 500 - Alexa broken: Commands only working for first song played

Thanks for coming back to us!

 

Can you tell me if you have always experienced this issue? Or is it something that has happened overnight?

 

Does Alexa otherwise function as expected?

 

I look forward to hearing from you!

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started.
Highlighted
Audible Advocate
  • 2
  • 7
  • 0
Registered since

Apr 4, 2020

Re: Home Speaker 500 - Alexa broken: Commands only working for first song played

Hi Jessie - to address your questions:

 

I have had these from the day I bought the Home Speaker. Apart from the issues highlighted earlier, Alexa seems to work fine.

Highlighted
Moderator

Re: Home Speaker 500 - Alexa broken: Commands only working for first song played

Thanks for getting back to us! This does seem strange, can I ask, do you use any other music services? If possible, please can you try this with them and see if the same issue occurs?

 

I look forward to hearing how you get on. 

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started.
Highlighted
Wistful Whisperer
  • 0
  • 2
  • 0
Registered since

Apr 5, 2020

Re: Home Speaker 500 - Alexa broken: Commands only working for first song played

Hi everybody,

Please, apologise for the delay in my answer and thanks for your interest.

Firstly, I confirm you that I'm using the premium family version of Spotify, and this one is my default music application.

As suggested, I tried to remove and re-install all the different accounts, apps and skills, on both the Bose Music application and the Amazon Alexa app. After that, the first and second time I asked Alexa to skip a song, it worked !. But unfortunately, finally Alexa told me the same as before: can't skip to next or previous song.

I'm not sure when this problem started, but around 2-3 months ago at least.

It's not a critical issue, but I hope someone find a solution or it will be fixed into a new FW update

Thanks.