Highlighted
DaveA
Audible Advocate
  • 2
  • 27
  • 0
Registered since

Dec 25, 2015

AM300 No power

My AM300 no longer powers on. I thought the bass was poor!! And this AM300 is a replacement for my original that had other issues. Not the quality of product I expect.
4 REPLIES 4
Moderator

Re: AM300 No power

Hi DaveA,

 

Thanks for the post, and I'm sorry to hear about the issues you're having with your AM300.

 

Where is your AM300 plugged into?  If it's plugged into a power strip, can you try connecting it directly to the wall?

 

When you plug the power back in, are there any LEDs that light up on the back of the bass module?

 

Let us know so we can get this resolved for you.

 

Best,

Brandon - Community Support

freedogski@hotmail.com
Quiet Contributor
  • 0
  • 2
  • 0
Registered since

Dec 21, 2018

Re: AM300 No power

Hi.  I am having same issue, no LED lights on AM300 when plugged in directly to wall socket.    Is this a firmware issue or faulty AM300 that needs to be replaced.  

 

AM300 was working but volume was low, so I opened sound app and then first thing was speaker update started and then no more LED on AM300

Community Manager

Re: AM300 No power

Hi freedogski,

 

Thanks for writing in!

 

Even though the LED is out on the AM300, if you put your hand on the bass module, does it vibrate at all during heavy bass?  If not, I definitely recommend reaching out to your local support team.  Just click HERE and select your country and Contact Us at the bottom.

 

Warm Regards,

Tony A

freedogski@hotmail.com
Quiet Contributor
  • 0
  • 2
  • 0
Registered since

Dec 21, 2018

Re: AM300 No power

Hi,

No power, no sound...  AM300 is back for warrantee repair work.

John