Highlighted
Silent Starter
  • 0
  • 1
  • 0
Registered since

Aug 15, 2017

Bose sound touch 20 display.

The display on my ST 20 used to show the station I was listening to. Ie) CBC and the volume. Now the display is black. The only thing illuminated is the confirmation it is connected to the WIFI. There is also some lag time when I unplug to reset before the music comes on.
3 REPLIES 3
Highlighted
Moderator - Retired
  • 0
  • 1641
  • 93
Registered since

Dec 5, 2016

Re: Bose sound touch 20 display.

Hi Kimbojangles,

 

I'm sorry to hear about this issue. Does anything appear on the display at any other time (other than the Wi-Fi indicator)? For example, if you press the preset numbers on the top of the system, do the preset numbers display on the screen? 

 

If your SoundTouch 20 is a series I or II model, could you please try the following product reset steps?

 

  1. Turn the system off
  2. On the system, push and hold the AUX button for 15 seconds
  3. Retest the system

 

If your SoundTouch 20 is a series III, could you please try these product reset steps?

 

  1. Turn off the product
  2. Unplug the product's power cord from the power outlet for 30 seconds
  3. Reconnect the power cord. A "beep-boop" uptone should sound within 10 seconds indicating the system is receiving power
  4. Retest the system

 

Thank you,

 

Brian

Highlighted
Silent Starter
  • 0
  • 1
  • 0
Registered since

Oct 7, 2017

Re: Bose sound touch 20 display.

I have the same issue. Tried the Aux for 15 seconds, tried unplugging but still nothing at the wifi logo.

Not happy as it worked fine when bought new and then I was "required to update" and since then it's been doing this....

Highlighted
Moderator - Retired
  • 0
  • 5748
  • 294
Registered since

Dec 5, 2016

Re: Bose sound touch 20 display.

Hi JD758,

 

Sorry to hear about the issues you're having with your system.  Are you saying that there is nothing showing up on the front of the system?  No display and no LED?  Or is one working?  Do you have an ethernet cable plugged into the system?

 

Thanks,

Brandon