Difficulties getting speakers to join group

Highlighted
Wistful Whiz

Difficulties getting speakers to join group

I'm having a problem with the SoundTouch app on one of my PC's.  When I start playing something on one speaker, and try to get others to join in, the app acts like its done it, but on the speaker I added nothing changes - no music starts, and the display doesn't change either.  On other devices that I have the app installed on (another PC, a couple of iPads and iPhones) its working correctly.  Previously it worked perfectly.

 

I don't know if this is relevant, but I recently changed from a single router to an Orbi mesh system.  The PC in question is connected via ethernet cable to the Orbi satellite.  Here I get 100% failures trying to initiate group playback.  If I switch it to WiFi, it still fails most of the time but succeeds occasionally.  The speakers are all connected via WiFi (reported signal strength ranges from fair to great)  as are all the other devices I have running the app.  Its only the one PC that's giving me issues.  I just got the Orbi a few days ago and thought this was working but now I am not sure if this issue coincided with getting the Orbi or if it suddenly started after that.

 

Also, again not sure if this is relevant but I renamed all my speakers at about the same time since they are all now in different rooms.

 

Other than these things, nothing has changed for me.  I tried rebooting the PC in question, disabling its firewall temporarily, uninstalling and reinstalling the SoundTouch app, removing and re-adding the speakers.  So far, nothing has helped.  

8 REPLIES 8
Moderator

Re: Difficulties getting speakers to join group

Hi Marty,

 

Thanks for reporting this.  

 

Do you happen to have a different PC that can be connected to that node via ethernet?  The fact that your other devices work without issue leads me to believe the issue lies with the specific computer.  

 

Is network connectivity otherwise fine from that mesh node?  

 

Best,

Brandon

Wistful Whiz

Re: Difficulties getting speakers to join group

Hi Brandon - issue might indeed be something about this specific computer but as far as I know nothing had changed with it when the problem started except that I joined it to my new Orbi network.  Unfortunately I don't have another computer with a physical ethernet port so I can't test as you requested.  

 

The networking seems ok for most purposes.   General web browsing, speed tests etc. from my PC all seem ok.  I can ping my 3 speakers from the PC in question, not really seeing any packet loss, ping time is sub-10ms for two of them but varies a bit for the third, into the several hundred ms range.  The app detecting the speakers (from all my devicess) seems to be an issue as well - its not really consistent - sometimes I need to exit the app and start again.  Also even though I removed all the speakers, re-added them (and now factory reset and added them again) sometimes when the app can't find them it shows the speakers dimmed out under their old, original names.  

 

In any case, once the speakers are detected everything works from all the apps, the only issue is just getting them to group using the PC.

Moderator

Re: Difficulties getting speakers to join group

Hi again,

 

Thanks for the update.  I checked your account and it looks like one of your systems still has a poor signal, however that shouldn't cause the issue we're seeing.

 

What is the operating system on this computer?  Windows 10?

 

I think at this point we would want to escalate this.  Are you able to collect SoundTouch log files from the PC and your SoundTouch systems? Instructions are HERE if needed.

 

Thanks,

Brandon

Wistful Whiz

Re: Difficulties getting speakers to join group

Hi - yes I will collect the log files and try to group the speakers while the logs are gathering.

 

Also, for some reason this morning it did work to get one of my ST20's to join the other one (didn't try the reverse) but still no luck getting my ST10 to join.

 

Moderator

Re: Difficulties getting speakers to join group

Thank you for collecting those.  

 

Are you normally able to to pair two out of three speakers from that computer, or has it strictly been single system playback since the issue appeared?

 

-Brandon

Wistful Whiz

Re: Difficulties getting speakers to join group

Previously (before Orbi install a few days ago and using old router) this PC controlled SoundTouch perfectly - speakers almost always detected ok, and could start playing on one of them and add in either of the other two or both with no issues.  I will gather logs and send them tonight.

Wistful Whiz

Re: Difficulties getting speakers to join group

Hi Brandon  - I uploaded the log files as requested - getting better results but still difficulty with "closet" speaker...

 

All this was from app running on my PC, unless noted:

 

Played sirius xm on office speaker (success)
Added master bedroom (success)
Removed master bedroom (success)
Added closet (fail)
Stopped office

 

Played sirius xm on master bedroom (success)
Added office (success)
Removed office (success)
Added closet (fail)
Stopped master bedroom

 

Played sirius xm on closet (success)
Added office (success)
Removed office (success)
Added master bedroom (success)
Stopped closet

 

Played spotify on office (success)
Added closet (fail)
"Removed" closet
Added master bedroom (success)
Stopped office

 

Played spotify on master bedroom (success)
Added closet (fail)
"Removed" closet
Added closet *using app running on iPhone* (success)
Turned off master bedroom

Closed app on PC

 

Moderator

Re: Difficulties getting speakers to join group

Great, thank you Marty.  I'll get this submitted.  We should hear back from the escalation team early next week.

 

In the meantime, let me know if functionality changes in any way.

 

Best,

Brandon