Highlighted
Silent Starter
  • 0
  • 2
  • 0
Registered since

Dec 4, 2017

Re: Disable Auto-off on Soundtouch 20?

Hi I have the exact problem with my echo dot and soundtouch 20 ii. I downloaded HomeBrew on my mac book pro. Where should I type in the telnet ip command?? Thanks. Hope Bose fix this auto-off asap. 

Highlighted
Audible Advocate
  • 0
  • 5
  • 0
Registered since

Nov 26, 2017

Re: Disable Auto-off on Soundtouch 20?

ya, let's hope!

 

The way I got it to work... In your Mac's terminal type:

 

>brew install telnet

>telnet 192.168.xx.xx 17000  (put your Soundtouch II's IP address instead of the Xs)

>sys timeout inactivity disable

>exit

 

Still working great for mine!  Let me know if you have any issues.

 

 

 

 

 

Highlighted
Silent Starter
  • 0
  • 2
  • 0
Registered since

Dec 4, 2017

Re: Disable Auto-off on Soundtouch 20?

omg I was just about to give up and go ahead connect one of my old school speakers just for my echo dot. 

 

I tried it again and now it works, no aux auto-off! Thank you so much.

 

Let me share where I got confused so hope someone like me can learn from my experience. 

 

I opened my TERMINAL app on my Mac and typed : 

 

>brew install telnet

>telnet 192.168.xx.xx 17000  (put your Soundtouch II's IP address instead of the Xs)

^^^^^^^^^^^^^^^^

This is where I was wrong. I went to my Preference on my Mac and found the IP there which is not the IP for my Soundtouch 20 ii. So I went to my SOUNDTOUCH app and found a different IP there. And finished rest of the typing as below. 

 

>sys timeout inactivity disable

>exit

 

Thank you so much!

 

Highlighted
Audible Advocate
  • 2
  • 7
  • 0
Registered since

Dec 18, 2017

Re: Disable Auto-off on Soundtouch 20?


@Henryj1234567 wrote:
It doesn’t work on the new Mac OS as they’ve removed Telnet from terminal. You can download a telnet client for free from the App Store though, or if you have windows use Microsoft telnet. Once in the client follow the instructions here, making sure both your speaker and the computer are connected to the same network:

https://ntotten.com/2017/01/19/disable-auto-shutoff-on-bose-soundtouch/

My IP was consistently 192.168.1.2 (instead of the Xs in the post).

If you have a soundtouch 10 and get it working let me know, I’ve been trying for months - get a confirmation but can’t get it to ‘stick’!!


I've been trying on the Soundtouch 10 and no luck.

I get an "OK" after typing the command but it still turns off after 20 min. I read you can also pass it a number so I tried setting it to a really high timeout (1 day) but still no luck

 

->sys timeout inactivity86400
Inactivity timer is overrided
->OK
 

 

This is so frustrating. This thread has been alive for almost 2 years now and there's still no solution from Bose. Why are they so non-committal with these feature requests?

Highlighted
Audible Advocate
  • 2
  • 7
  • 0
Registered since

Dec 18, 2017

Re: Disable Auto-off on Soundtouch 20?


@Jason_G wrote:
To clarify - The ability to disable the auto shutoff function for better integration with Alexa type devices is currently being looked into by our engineering team for a future update.  
We'll share more information about the progress of this as we know more. 

 

 

Jason -- you posted this a year and half ago. Is this still being "looked into"? It seems you guys only tried solving bluetooth but not AUX.

Why is this such a difficult thing to code?

Highlighted
Wistful Whisperer
  • 0
  • 4
  • 0
Registered since

Jan 4, 2018

Re: Disable Auto-off on Soundtouch 20?

I can't get past the "Trying 192.168.X.XX". Says "Operation Timed Out: Unable to connect to remore host". Using a legacy OSX Sierra telnet file copied over to High Sierra. Soundtouch 10. 😞

Highlighted
Audible Advocate
  • 4
  • 13
  • 0
Registered since

Oct 8, 2017

Re: Disable Auto-off on Soundtouch 20?

What are you putting instead of the’X.XX’ ?

You need to find the IP address of the ST10, should be found by going into your router settings and looking for connected devices. Mine is 192.169.2.1 (I think!) will confirm when I get home.

If you get it working let me know I haven’t tried the legacy telnet yet! Tried it again the other day on my ST10, get a confirmation but it still won’t ‘stick’
Highlighted
Audible Advocate
  • 3
  • 12
  • 0
Registered since

Nov 5, 2017

Re: Disable Auto-off on Soundtouch 20?

Try installing telnet onto High Sierra via home brew...

 

https://medium.com/@blackSource/bring-telnet-back-on-macos-high-sierra-11de98de1544

 

Alternatively, you can install a 3rd party telnet client such as Zoc...

 

https://www.emtec.com/download.html

Highlighted
Audible Advocate
  • 3
  • 12
  • 0
Registered since

Nov 5, 2017

Re: Disable Auto-off on Soundtouch 20?

Try installing telnet onto High Sierra via Home Brew...

 

https://medium.com/@blackSource/bring-telnet-back-on-macos-high-sierra-11de98de1544

 

Alternatively, you can install a third party Telnet client such as Zoc...

 

https://www.emtec.com/download.html

Highlighted
Wistful Whisperer
  • 0
  • 4
  • 0
Registered since

Jan 4, 2018

Re: Disable Auto-off on Soundtouch 20?

Sorry I am inputting the IP address of the ST 10... just did not want to confuse anyone thinking mine's IP is thier's so I used the X's. However I was ussing the IP address the Soundtouch app was telling me. This was NOT the IP address my router had assigned. Switching to that Telnet connected and the command "sys timeout inactivity disabled" netted me an OK. Fingers crossed it takes. Will update here in 30 minutes or so.