Highlighted
Silent Starter
  • 0
  • 3
  • 0
Registered since

Nov 14, 2017

Hot electrical smell from acoustimass 300 at full power

When at full power a strong burning electrical smell comes from bass speaker unit. When volume is turned down smell lowers as well. This smell fills my whole living room and attached rooms. I've read in other post that it's a "Glue adhesive " from assembly, and will go away, but has not gone away from daily use. Anybody else have this concern? It's very unpleasant to smell and feel for the amount of money I've spent on this system, I should not have this condition. Other than the smell concern I'm very happy with the sound bar and bass unit. Please share any related concerns.

4 REPLIES 4
Highlighted
Moderator - Retired
  • 0
  • 5748
  • 294
Registered since

Dec 5, 2016

Re: Hot electrical smell from acoustimass 300 at full power

Hi Gjoeherna50,

 

Thanks for the post, and sorry to hear about the issues you've been having.

The smell should not be this strong, or long lasting.  As well, it shouldn't really smell like burning electronics.  I'm thinking there might be an issue with your AM300.  I would contact your local support center to arrange for service.

 

Let me know if you have any further questions or concerns.

 

Best Regards,

Brandon

Highlighted
Silent Starter
  • 1
  • 1
  • 0
Registered since

Mar 18, 2018

Re: Hot electrical smell from acoustimass 300 at full power

Hi have the same problem did you get this fixed by chance?
Highlighted
Silent Starter
  • 0
  • 3
  • 0
Registered since

Nov 14, 2017

Re: Hot electrical smell from acoustimass 300 at full power

Yes, I contacted Bose and sent bass unit in for warranty repairs. It came back with same condition and contacted again, they then replaced unit with a new bass unit. The new bass module doesn't smell like my original. My recommendation is to contact warranty thru Bose asap. Be sure to tell them all the conditions that make the concern occur. My unit smelled very heavy of electrical smell after medium to high volume. My replacement does not smell what so ever even at full power for 2 hours straight.

Highlighted
Silent Starter
  • 0
  • 3
  • 0
Registered since

Nov 14, 2017

Re: Hot electrical smell from acoustimass 300 at full power

After sending bass unit in for warranty repairs , it continued to smell. I again contacted Bose and they sent a new replacement. The new unit does not smell , even at full power for 2 hours at full volume power. I'm sure by research I have done that Bose is aware of this condition. 


@Brandon_Mwrote:

Hi Gjoeherna50,

 

Thanks for the post, and sorry to hear about the issues you've been having.

The smell should not be this strong, or long lasting.  As well, it shouldn't really smell like burning electronics.  I'm thinking there might be an issue with your AM300.  I would contact your local support center to arrange for service.

 

Let me know if you have any further questions or concerns.

 

Best Regards,

Brandon