Highlighted
Participant
  • 1
  • 7
  • 0
Registered since

Aug 22, 2017

Improvement from Update

I had messaged several times about my SoundTouch 20 model III dropping connection to the router three or four times per hour for anywhere from five to 15 seconds. It was really annoying! All my computers are Macs, and my household has iPads and iPhones. Our router is an older Apple AirPort Extreme that otherwise seemed to be workng just fine delivering high-speed video, etc.

 

We were away from home beginning Feb. 13th and just returned on the 27th. When I fired up my Mac that has the SoundTouch App, and it loaded the new update, then the speaker updated, the dropped connection problem disappeared! Finally, for the first time since last summer, my SoundTouch 20 plays my favorite internet radio stations without annoying interruptions. THANK YOU, BOSE!

 

The SoundTouch 20 is in a large Kitchen-Family Room area. My plan now that all's good is to get a SoundTouch 10 to put on the other side to just fill the room with music.

 

PS: We listen to mostly classical, and All Classical in Portland, OR, is our station of choice.

4 REPLIES 4
Highlighted
Participant
  • 0
  • 17
  • 0
Registered since

Jul 13, 2015

Re: Improvement from Update

Which version of the firmware seemed to fix the problem for you?

 

I am now running 18.0.11 on my SoundTouch 20 model III (for the past week or so) and am still having daily dropped connections to the router requiring reboot of the SoundTouch (almost) every time before use.  Like you, I was hopeful the problem had abated for the first few days running 18.0.11 - and then it resumed. Alas. 

Highlighted
Expert
  • 286
  • 1387
  • 30
Registered since

Nov 12, 2015

Re: Improvement from Update

Try unplugging your modem, wireless router and computer(if in your network) let them sit for a couple minutes. Also reboot all your ST speakers(soft reset) while waiting. Then restart your computer>modem >wirelss reouter.

 

That worked for me after the last problematic firmware update. I guess everything needs a little clearing of the old setup.

 

None of this precedure should effect your settings.

 

I listen to Smoothjazz.com based in Monterey California. I live in Victoria BC, but l have been listening to that Jazz station since I started listening to Internet Radio.

 

 

 

Highlighted
Advocate
  • 55
  • 157
  • 4
Registered since

Nov 1, 2015

Re: Improvement from Update

A couple of things to try that have helped my 6 x ST setup - use the 5ghz wifi network if your router has it, also set up static (fixed) IP adresses in the router for your ST boxes.

Also your ST20 has a network point at the back - if you can wire it directly to the router then that would be the best way, avoid wifi connections altogether...

Highlighted
Contributor
  • 5
  • 16
  • 0
Registered since

Jan 4, 2015

Re: Improvement from Update

Hi LennyR,

I had the same issue in the past. My soundtouch speakers did disconnect from network on a regular basis, but not at the same time.

I've got the feeling that the speakers are very sensible for interferance.

I've checked the Wifi channels of my own router and the wifi networks of my neighbourgs. I found out that there were a few wifi networks on the same channel. After changing my wifi channel the issue was resolved.

Also I gave my soundtouch devices a fixed IP address

I hope this is helpfull for you.