Highlighted
Bnccri
Silent Starter
  • 0
  • 1
  • 0
Registered since

Mar 3, 2019

SoundTouch 300 Sound Bar intermittent sound

Hello. Just updated today 03/03/19 to the latest firmware 20.0.10. I have a SoundTouch 300, accoustimas 300 and the invisible satellites. Since the update I’m having issues with the sound. The subwoofer makes pooping sounds and the satellites intermittent sound and loses it and then comes back. I’ve never had this issue before. I’m connected using HDMI ARC but I have the same issue while using Bluetooth. I have restored to factory settings, paired, reconfigure but the problem persists. I want to go back to previous firmware that worked properly. How can I do that? Thank you
1 REPLY 1
Highlighted
Moderator - Retired
  • 0
  • 270
  • 9
Registered since

Feb 26, 2019

Re: SoundTouch 300 Sound Bar intermittent sound

Hi Bnccri, 

 

Thank you for your post and welcome to the community. I'm sorry to hear that you are having this issue

 

I'm afraid there is no function to revert the systems firmware to a previous version. 

 

As you have tried the Factory Reset for the system, this would normally resolve the issue. May I ask have you tried connecting an optical cable from the ST300 to your television to see if this stops the intermittent audio?

 

In relation to the popping noise from the Accoustimass Bass Module, we would advise to disconnect it from power for roughly 5 minutes and reconnect it. If this does not resolve this issue, I would suggest to try to connect a Accoustimas Bass Module cable to the ST300. If you require this, you can contact your local Customer Support Team who will be happy to provide this to you.

 

If you select this link - Contact Us, select your region ad scroll to the bottom of the page and select "contact us". This will provide you with their contact number.

 

If this helps, please let us know.

 

Many thanks

 

Leon_C - Community Support