Ballon
Quiet Contributor
  • 0
  • 3
  • 0
Registered since

Jul 27, 2018

Soundtouch 10 losing connection

My 2 Soundtouch 10s have become virtually unusable as they lose connection most of the time. They are right next to my router, so that's not the problem. They are both connected at 2.4ghz. I have a fibre 25mbps connection which works quickly on all other devices.

I've reconnected them countless times, rebooted the router etc etc but they just not longer work beyond a couple of hours.

Any suggestions at all that will help would be greatly appreciated.
Thanks
1 ACCEPTED SOLUTION

Accepted Solutions
Moderator - Retired
  • 0
  • 3221
  • 127
Registered since

Dec 5, 2016

Re: Soundtouch 10 losing connection

Author Accepted Answer selected by Ballon

Hello Ben,

 

Perfect, thank you for getting back to me. Looking forward to hearing your results after the update.

 

Regards,

Joel 

View solution in original post

5 REPLIES 5
Community Manager

Re: Soundtouch 10 losing connection

HI Ballon

 

Thanks for posting in the community!  Sorry to hear about the connectivity issues, but would be glad to help!

 

I have a few questions to narrow down the issue:

  • What color are the Wi-Fi indicators when the issue happens?
  • Is this happening while the speakers are in a stereo pair/play all/individually?
  • Does this happen on one source of music or all sources?
  • Did this ever work in the past?

 

Let us know so we can help resolve the issue!

 

Warm Regards,

Tony A - Community Support 

Ballon
Quiet Contributor
  • 0
  • 3
  • 0
Registered since

Jul 27, 2018

Re: Soundtouch 10 losing connection

Hi,
I Spotify via WiFi but the same thing happens when I try to connect from my phone using Bluetooth.

If I separate the stereo pair, I can play via each speaker independently, but not together.

When I try to play from either the Spotify app or the Soundtouch app, it starts with both white wifi lights flashing for up to a minute before turning to a steady orange light.

If I reboot the wifi router and the speakers, it will work for a time, but after a day it will stop working again.

I think it must be to do with the 2 speakers struggling to pair over the wifi network.

It used to work most of the time until around six months ago.

I would love to solve the problem as I just can't use the speakers as a stereo or grouped pair any more.

Look forward to hearing from you,
Ben
Moderator - Retired
  • 0
  • 3221
  • 127
Registered since

Dec 5, 2016

Re: Soundtouch 10 losing connection

Hello Ben,

 

Thank you for all the details, we appreciate this!

 

If you open the SoundTouch application and navigate to Settings>About>and select each SoundTouch 10, can you give us the software version of each system and the RSSI value? How far are the 2 SoundTouch 10's from each other

 

We also have an update coming today if you've not already received it which will show 19.0.13 under each system. Is the issue still happening after this update?

 

Regards,

Joel

Ballon
Quiet Contributor
  • 0
  • 3
  • 0
Registered since

Jul 27, 2018

Re: Soundtouch 10 losing connection

Hi,
Thanks for the reply. The one speaker is right next to the router and the 2nd is 2 metres away.

They both show a "great" connection on RSSI, but neither have updated from the 19.0.5 firmware version, so I'll wait for that to come through and see if it has any impact.

Thanks again,
Ben
Moderator - Retired
  • 0
  • 3221
  • 127
Registered since

Dec 5, 2016

Re: Soundtouch 10 losing connection

Author Accepted Answer selected by Ballon

Hello Ben,

 

Perfect, thank you for getting back to me. Looking forward to hearing your results after the update.

 

Regards,

Joel 

View solution in original post