Ravenclaw74656
Quiet Contributor
  • 0
  • 1
  • 0
Registered since

Oct 25, 2018

Soundtouch PlayAll/Group - Asus AiMesh

Hi all, not sure if this has already been posted (couldn't see it when I was looking). Been having recent play all / can't find media source problems for the last few months. The app would think it was playing, but no sound would come out of the speakers. Or sometimes it was delayed, intermittent, would randomly drop, unable to find sources, etc etc. Each day was a new interesting combination of speakers, with no rhyme or reason, but I couldn't get them all to work together.

 

Backstory

Eventually I twigged and realised this happened around the time I switched over to AI Mesh on my routers (Asus's mesh network mode). I tried all sorts, repositioning, confirming signal was great, static IPs, etc etc. Didn't get much luck. I had a look on these forums but didn't find anything, then figured, why not check Sonos; whatever backend proprietary wizardy soundtouch uses, Sonos must use something similar right? Turns out their community has been having similar problems with mesh networks to my soundtouch issues. One of their users managed to find the solution, so I changed the same setting on my routers. Quick restart of the router and my soundtouch speakers, and they instantly started working correctly.

 

The fix

Wireless > Professional > Airtime Fairness.

 

Disable this. Restart the router. Turn off the soundtouch devices and back on, and enjoy :).

 

Hope this helps someone. I've tried to drop enough keywords in here so hopefully anyone who googles the same combination of words I did will find this post.

1 REPLY 1
Highlighted
Moderator - Retired
  • 0
  • 3221
  • 127
Registered since

Dec 5, 2016

Re: Soundtouch PlayAll/Group - Asus AiMesh

Hello Ravenclaw74656,

 

Thank you for posting!

 

I can't even express how thankful we are for information on this. I'm sure this will be beneficial to other community members.

 

Have a good day!

 

Warm Regards,

Joel - Community Support