Highlighted
DaveElliot79
Silent Starter
  • 0
  • 1
  • 0
Registered since

Jul 8, 2018

Speakers Cutting Out Intermittently When On Group Play

Hello all,

I have a SoundTouch 30 (w/ AirPlay, no BlueTooth), 2 SoundTouch 10’s (w/ BlueTooth, no AirPlay) and a SoundTouch Wireless Link all in different rooms.

With Bose dropping AirPlay and switching to BlueTooth (thanks Bose!) the only way to group play is to connect to one of the SoundTouch 10’s or the ST Wireless Link then group play from there... the problem with this is that the individual speakers keep intermittently cutting out. Sometimes it’s worse than others but it’s pretty much unusable in group mode as a result... (The multi-room setup was the very reason I purchased so many Bose Speakers in the first place).

• I play the music from an iMac which is connected to the network via Ethernet cable.
• I have purchased and installed a WiFi extender and all speakers are on the same channel.
• There is no block between the iMac and the Speaker I’m BlueTooth-ing to (although I’ve tried all three blue tooth speakers with the same result).
• All speakers have a “Great” connection to the WiFi.
• My internet speeds are super fast fibre optic.
• I’ve reset everything (router, iMac, speakers) time and time again.

I’m tearing my hair out and am regretting adopting a Bose setup. Any help would be massively appreciated.
1 REPLY 1
Mattyboy
Vocal Volunteer
  • 119
  • 112
  • 0
Registered since

Jan 2, 2017

Re: Speakers Cutting Out Intermittently When On Group Play

Might be worth taking a look at the "Play All Not Working" thread, since the last update, at the top. Lots on here to read.