Highlighted
Contributor
  • 1
  • 12
  • 1
Registered since

Oct 20, 2017

Spotify issue 3103 on SA-5 Amplifier

I have Soundtouch SA-5 Amplifier and premium Spotify. I"m having same issues as other Bose users on Soundtouch speakers where sound plays for a while and then consistently drops in and out. Apparently Bose issued update in January this year but it's not making any difference to my system.

 

Any ideas re what to do??

 

thanks

Kate

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Contributor
  • 1
  • 12
  • 1
Registered since

Oct 20, 2017

Re: Spotify issue 3103 on SA-5 Amplifier

Author Accepted Answer selected by KPS

Brandon - thanks again for the advice. I think I may have fixed the problem. Frustrated at ongoing problems I repeated disconnect and reconnect of the speaker and rebooted router. All with music services setting for Spotify set in SoundTouch at lowest quality - Fastest Streaming.

 

Touch wood, this seems to have fixed the problem

 

I've also confirmed that the issue was just with Spotify - wasn't getting issues with my music library or internet radio.

 

So if you get anyone else with the 3013 issue, key things I'd recommend would be reboot of both Soundtouch speaker and router and go to lower quality streaming (under Soundtouch speaker/Settings/Music Services/Spotify.

 

I'll continue to test it out this week,but so far all good.

 

Thanks again for your advice,

 

Kate

View solution in original post

8 REPLIES 8
Highlighted
Moderator - Retired
  • 0
  • 5748
  • 296
Registered since

Dec 5, 2016

Re: Spotify issue 3103 on SA-5 Amplifier

Hi Kate,

 

Thanks for the post, and I'm sorry to hear about the difficulties you're having with Spotify.

 

How long does it take for audio to drop out from your SA-5?

 

Does this happen with only Spotify, or are there other sources this happens with (like internet radio)?

 

Best,

Brandon - Community Support

Highlighted
Contributor
  • 1
  • 12
  • 1
Registered since

Oct 20, 2017

Re: Spotify issue 3103 on SA-5 Amplifier

Brandon - many thanks for your response. The issue is only with Spotify as far as I can tell - no issues with drop out listening to ABC. I haven't been listening thru Soundtouch to my internet library much - mainly using Spotify.

 

After reading thru responses to similar issues, I rebooted my router and also adjusted my speaker so it went from top level service to next level down (I think that's best available). These two things seemed to work much better with longer time period before drop out started and then less frequent.

 

Then today, it's dropping out repeatedly with error 3103 right from start. I checked my internet connection and I'm getting 43.65 Mbps download and 14.66 Mbs upload.

 

Only thing I haven't don't yet is delete and reload my speaker

 

Any advice you can provide would be much appreciated - really annoying having Spotify music dropping in and out repeatedly.

 

Regards

Kate

Highlighted
Moderator - Retired
  • 0
  • 5748
  • 296
Registered since

Dec 5, 2016

Re: Spotify issue 3103 on SA-5 Amplifier

Hi again Kate,

 

Thanks for the info.

 

When you say you adjusted the speaker from top level service to the next level down, what do you mean by that?  Is that a setting in your router for prioritization?  If it is, can we disable prioritization entirely?  

 

As well, can we check the RSSI value for the SA-5 in the SoundTouch app?  To do this, go into the SoundTouch App and go to Settings>About>your SA-5.

 

Best,

Brandon

Highlighted
Contributor
  • 1
  • 12
  • 1
Registered since

Oct 20, 2017

Re: Spotify issue 3103 on SA-5 Amplifier

Brandon - sorry for the delay in responding.

RSSI Signal Strength says 'Good'.

I changed the speaker settings for Spotify under Settings/Music Services/Spotify. You have three options - Best Quality/Balanced Quality/Fastest Streaming. 

Given ongoing issues with error 3103 listening to Spotify, I've just reclassifed speaker settings down to Fastest Streaming to see if that any better.

 

Kate

Highlighted
Contributor
  • 1
  • 12
  • 1
Registered since

Oct 20, 2017

Re: Spotify issue 3103 on SA-5 Amplifier

Brandon - issues still occurring with Spotify dropping out and error 3103 again. Frequently. So going to lowest speaker setting 'Fastest Streaming' under Spotify made no difference. I have since disconnected and reconnected SA-5 amplifier as speaker and rebooted router. Only difference is that drop out took a bit longer to occur. Now it's back. Regularly.

 

Any suggestions or advice would be appreciated.

 

Kate

Highlighted
Moderator - Retired
  • 0
  • 5748
  • 296
Registered since

Dec 5, 2016

Re: Spotify issue 3103 on SA-5 Amplifier

Hi Kate,

 

Thanks again for the info.  

 

What is the brand and model of your wireless router?

 

Have you tried playing to your SA-5 via the Spotify app directly?  I don't think it should make a difference, but I'd like to cover all possible troubleshooting steps.

 

Is it possible to connect the SA-5 to your router via Ethernet cable?  Again, I don't think it'll help since your system has a 'Good' signal but we want to cover everything.

 

Best,

Brandon

Highlighted
Contributor
  • 1
  • 12
  • 1
Registered since

Oct 20, 2017

Re: Spotify issue 3103 on SA-5 Amplifier

Author Accepted Answer selected by KPS

Brandon - thanks again for the advice. I think I may have fixed the problem. Frustrated at ongoing problems I repeated disconnect and reconnect of the speaker and rebooted router. All with music services setting for Spotify set in SoundTouch at lowest quality - Fastest Streaming.

 

Touch wood, this seems to have fixed the problem

 

I've also confirmed that the issue was just with Spotify - wasn't getting issues with my music library or internet radio.

 

So if you get anyone else with the 3013 issue, key things I'd recommend would be reboot of both Soundtouch speaker and router and go to lower quality streaming (under Soundtouch speaker/Settings/Music Services/Spotify.

 

I'll continue to test it out this week,but so far all good.

 

Thanks again for your advice,

 

Kate

View solution in original post

Highlighted
Moderator - Retired
  • 0
  • 5748
  • 296
Registered since

Dec 5, 2016

Re: Spotify issue 3103 on SA-5 Amplifier

Hi again Kate,

 

Thanks for posting the (possible) resolution to your issue.  Let us know what happens.

 

Best,

Brandon