Highlighted
Contributor
  • 3
  • 11
  • 0
Registered since

Oct 8, 2017

W10 error 6304

just cannot get soundtouch to see my Library

w10 headless server, installed soundtouch and windows media player (have also tried itunes)

no matter what i do it will never see my Library always comes back with error 6304

 

firewall/antivirus turned off

left overnight to index

removed all speakers and re-added

uninstalled and reinstalled software

removed Library and readded

 

what am i missing??

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Moderator - Retired
  • 0
  • 3221
  • 129
Registered since

Dec 5, 2016

Re: W10 error 6304

Author Accepted Answer selected by Davedavedave

Hello @Davedavedave,

 

I have just looked at your ticket. Can you check and see what is running on Port 8085? You can do this by looking at the Resource Monitor. There is either something running or blocking that port. If you find out what it is, can you test by stopping whatever process it is and remove and re-add your library?

 

Kind Regards,

Joel

View solution in original post

19 REPLIES 19
Highlighted
Advocate
  • 42
  • 132
  • 0
Registered since

Dec 21, 2017

Re: W10 error 6304

Error 6304 was 'solved' in the ST archive here.  Looks like you've already done most, if not all of the steps though.  A couple of days ago I read somewhere that the latest version of AVG antivirus was causing new issues.  I know you said you disabled antivirus but if you are using AVG, perhaps have a look at settings within the software.  I believe the solution was there.  Good luck... hopefully it's as simple as that.

Highlighted
Advocate
  • 42
  • 132
  • 0
Registered since

Dec 21, 2017

Re: W10 error 6304

Ah!  Here it is.  I know it's a longshot, but it specifically relates to AVG Internet Security users and Bose SoundTouch software/app.

Highlighted
Contributor
  • 3
  • 11
  • 0
Registered since

Oct 8, 2017

Re: W10 error 6304

thanks for the reply,

 

using kaspersky, tried it with it disabled no difference

works fine on the main pc,  just cannot get it to work on the server

Highlighted
Moderator - Retired
  • 0
  • 3221
  • 129
Registered since

Dec 5, 2016

Re: W10 error 6304

Hello Davedavedave,

 

Thank you for the post and I'm sorry to hear this. Even disabling Kaspersky doesn't shut down the program, it is still running in the background. We would need to make exceptions in it for SoundTouch to work properly. What version of Kaspersky do you have?

 

 

Hi SkyYYZ,

 

I appreciate you helping out!! Thank you!

 

Kind Regards,

Joel - Bose Support

Highlighted
Contributor
  • 3
  • 11
  • 0
Registered since

Oct 8, 2017

Re: W10 error 6304

Hi,

 

its kaspersky total security, have been into settings and bose software is allowed

 

running the same on main pc, that has no issues

thanks

Highlighted
Moderator - Retired
  • 0
  • 3221
  • 129
Registered since

Dec 5, 2016

Re: W10 error 6304

Hi Davedavedave,

 

Thank you for getting back to me with the information. There might be a few settings we may need to adjust, I do understand that the other computer has it as well, but there may be a possibility something is different.

 

Can you check and tell me what your network adapter is set to(Private or Public)? Is Media Streaming enabled as well on the PC(under Network then Sharing Center)?

 

Kind Regards,

Joel - Bose Support

 

Highlighted
Contributor
  • 3
  • 11
  • 0
Registered since

Oct 8, 2017

Re: W10 error 6304

hi 

 

network is set to private and media streaming is turned on

 

thanks for the reply

Highlighted
Moderator - Retired
  • 0
  • 3221
  • 129
Registered since

Dec 5, 2016

Re: W10 error 6304

Hello Davedavedave,

 

Thank you for the additional information. Lets take a look at network settings in Kaspersky.

 

Network Status in Kaspersky:

 

  • Open the Settings window of Kaspersky Total Security 
  • In the Settings window, go to the Protection Center section and select Firewall in the right frame
  • In the Firewall settings window, click the Networks link
  • In the Manage networks window, right-click the connection for which you would like to change the status, and select the status from the context menu
  • In the Application Rules window, click Edit
  • Make sure to set this to Trusted Network

Let me know the results.

 

Kind Regards,

Joel - Bose Support

Highlighted
Contributor
  • 3
  • 11
  • 0
Registered since

Oct 8, 2017

Re: W10 error 6304

thanks for the reply

 

its nothing to do with kaspersky or any firewall settings

i uninstalled kaspersky and rebooted and just to be sure disabled w10 firewall

no difference

 

what else now?