• 2
  • 11
  • 0
Registered since

Jan 13, 2018

lost ability to reconnect with Soundtouch 30

Soundtouch 30 greyed out on my mac so tried a factory reset. When tried to reconnect via USB it said it was already connected (it wasn't). Tried setting up via internal wifi but no connection (even though Soundtouch signal found on wifi).

Had been able to connect via iPhone but whole thing now impossible to connect


Re: lost ability to reconnect with Soundtouch 30

Hello cyoungson,


Thanks for posting!


I'm sorry to hear that you've been unable to reconnect to your SoundTouch 30. I would love to help resolve this so you can resume using the speaker with its full potential.

Have you been able to connect to your speaker without issues for a while or have you recently set the speaker up and are coming across this issue?


Factory resetting the speaker was a great step to take. Could you please do this again to erase the steps you have since taken. (Hold 1 and Volume- for 10 seconds).

When you say you tried with internal Wi-Fi, do you mean the Wi-Fi broadcasted by the speaker? If not, please follow these steps to complete the Alternate Setup


I look forward to hearing back from you.


Warm regards,

Charlotte G - Community Support


Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!