Highlighted
Silent Starter
  • 0
  • 3
  • 0
Registered since

Nov 2, 2014

radio and cd not working?

my soundtouch is working perfectly fine. 

 

but once i turned to radio, whether FM or AM, it suddenly stops and not working. But turning on and off my soundwave system did not resolve the problem.  what am i suppose to to?

3 REPLIES 3
Highlighted
Moderator - Retired
  • 0
  • 1641
  • 93
Registered since

Dec 5, 2016

Re: radio and cd not working?

Hello drcristobal,

 

Thank you for your inquiry. I'm sorry to hear that you are experiencing radio and CD playback issues with your Wave SoundTouch Music System. Curiously, have you tried resetting the system? If not, you can do so by going through the following steps:

 

  • Unplug the speaker from power
  • Wait 1 minute
  • Reconnect the system to power
  • The system should go through a quick reset process
  • When the time appears back on the display, try retesting the system

 

If this doesn't work, I have a few followup questions:

 

  • When trying to play CD and/or radio, what appears on the display (playback timer, clock, artist/track info)?
  • Are you able to hear any audio while listening to radio (even static)?
    • Does this issue occur with all FM and AM radio stations?
  • Please be sure that nothing is connected to the system's headphone jack. 

 

Let us know if these steps help!

 

Best regards,

 

Brian

Highlighted
Silent Starter
  • 0
  • 3
  • 0
Registered since

Nov 2, 2014

Re: radio and cd not working?

Hi Brian,

Even unplugging and turn it back on, still the radio and even the cd isn't working.  

No other device is connected to the system. 

The system still connects to the wifi and I can use the soundtouch app. 

I reset the system but still didn't work. 

Only the clock and the station is displayed. I can't even search for other stations. No static sound also.

 

Highlighted
Moderator - Retired
  • 0
  • 4116
  • 230
Registered since

May 16, 2016

Re: radio and cd not working?

Hi drcristobal,

 

Thank you for responding. I'm sorry to hear that this is still ongoing. If the reset didn't fix it I'd recommend reaching out to your local service group HERE so they can assist.  

 

Kind Regards