Highlighted
Participant
  • 0
  • 3
  • 0
Registered since

Aug 31, 2018

sound lag of ST 10

I used a pair of ST 10  as my laptop's speaker through bluetooth.  Its sound always lagged for about 3 sceonds.  It is fine for listen music, but I cannot watch vedio at all.  Any idea how to fix it?

3 REPLIES 3
Highlighted
Community Manager - Retired
  • 0
  • 3053
  • 125
Registered since

Mar 15, 2018

Re: sound lag of ST 10

Hello ruanqizhen

 

Thanks for posting in the community!

 

This is actually normal operation with this feature.  The reason there is an inherent delay is because the first speaker getting the source audio has to relay the sound through the router and then back to the 2nd speaker in the pair.

 

Warm Regards,

Tony A - Community Support 

Highlighted
Participant
  • 0
  • 3
  • 0
Registered since

Aug 31, 2018

Re: sound lag of ST 10

Hi Tony,

 

Thank you for the answer.  Does Bose have any plan to fix it?

 

This may be too tech details, but I'm wondering why ST uses one device as a relay.  I'm just thinking, both devices can receive the bluetooth signal, and if they pickup the L and R channels respectivly, they can be a stereo pair without delay.

Highlighted
Community Manager - Retired
  • 0
  • 3053
  • 125
Registered since

Mar 15, 2018

Re: sound lag of ST 10

Hello ruanqizhen

 

Thank you for replying. 

 

What happens is the source device uses the A2DP profile which sends a stereo signal.  The source device won't be able to provide a separate left and right channel to each speaker using Bluetooth.  With that said, since the SoundTouch products use a Wi-Fi chip set to distribute audio through the home, there will be this inherent delay.

 

Warm Regards,

Tony A