OscarW
Contributor
  • 1
  • 6
  • 1
Registered since

Nov 13, 2020

AirPlay not working after iOS 14.2

Hi,

I have two soundtouch 20 series II speakers that support airplay but Bluetooth. Since iOS 14.2, I’m not able to stream music through airplay from iPhone to those speakers. I can see those speakers on the airplay device list. However, music keeps playing on iPhone when I choose the speaker to airplay. The airplay works when I stream from MacBook, but the iPhone and iPad just won’t work. I’ve tried everything, rebooting, factory reset.. And all system firmware is up to date. 

Please help.. 

1 ACCEPTED SOLUTION

Accepted Solutions
OscarW
Contributor
  • 1
  • 6
  • 1
Registered since

Nov 13, 2020

Re: AirPlay not working after iOS 14.2

Author Accepted Answer selected by OscarW

Hi,

Suddenly my AirPlay through Bose speaker is working, after I upgraded to iOS 14.5.1. 
Thanks for suggestion. 

View solution in original post

5 REPLIES 5
Hector_B
Moderator

Re: AirPlay not working after iOS 14.2

Hey OscarW, 

 

Thank you for reaching back out to the Community today! We're sorry to hear that you are having issues with streaming to your speakers via Airplay. 

 

We appreciate the steps that you have performed so far and we are surprised this hasn't resolved your issue. 

 

Can you please let us know if the iPhone and iPad are able to connect via Airplay to any other devices? I would also like to know if you have performed a reset on the Apple products also? 

 

I look forward to hearing back from you with further information on this. 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
OscarW
Contributor
  • 1
  • 6
  • 1
Registered since

Nov 13, 2020

Re: AirPlay not working after iOS 14.2

Thank you for your response.

 

The AirPlay does work when I try to stream from my iPhone to other devices such as my Apple TV. I haven’t tried to reset my iPhone since AirPlay works on other devices. Thanks. 

Jeff_G
Moderator

Re: AirPlay not working after iOS 14.2

Hi Oscar, 

 

Thanks for getting back in touch. 

 

For further testing, I suggest you try disconnecting your router from power for 5 minutes, plug it back in, then re-test. This may help clear out any minor bugs present in the network that, while appears to work fine with other devices, may only be compromising the desired products. 

I also recommend checking your iPhone/iPad are connected to the same specific network as the speaker. Your router may have a 2.4Ghz band and a 5Ghz band, so if the iPhone is on a different band, Airplay may not work correctly. Further to this, having the 2.4 and 5Ghz bands synchronized can cause unexpected behavior. We have a list of recommendations for router settings here. Please check your router settings match those on the page as this will ensure the best communication and performance of your SoundTouch products. 

 

Finally, iOS 14.5 was released earlier this week, it's always a good idea to be running the latest firmware, so please ensure your products are up to date.

 

I hope this helps! Be sure to let me know how you get on. 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
OscarW
Contributor
  • 1
  • 6
  • 1
Registered since

Nov 13, 2020

Re: AirPlay not working after iOS 14.2

Author Accepted Answer selected by OscarW

Hi,

Suddenly my AirPlay through Bose speaker is working, after I upgraded to iOS 14.5.1. 
Thanks for suggestion. 

View solution in original post

Liam_G
Moderator

Re: AirPlay not working after iOS 14.2

Hey Oscar, thank you for reaching back out to us!
 

I'm glad to hear the latest iOS update has allowed you to stream from Airplay again. Thanks as well for marking that as a solution, so that any other users with a similar issue can see what worked for you!
 

If there is anything else we can help with in the future, please don't hesitate to message again!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!