Highlighted
Participant
  • 0
  • 7
  • 0
Registered since

Aug 28, 2017

Error playing library on NAS

I have my music library on. WD Mybookliveduo NAS streaming via DLNA. The soundtouch10 can see all the tracks, it will play the “Recently Added” playlist and will play by Alum or Artist but when I select “All Music” to play the whole library it returns error 1647.

 

I have rebooted the speakers and the NAS without success.

3 REPLIES 3
Highlighted
Moderator

Re: Error playing library on NAS

Hello RossC, 

 

Thanks for posting on the Bose Comunity Forums. 

 

When it comes to adding a NAD drive WD MyCloud and Synology NAS drives are recommended. However, SoundTouch systems are not fully DLNA complaint and may not have full functionality with all NAS drives—including some variants of recommended drives, such as MyCloud Home.

 

I am more than happy to work with you and see if we can get this set up. Can you please confirm that these are the steps you are following? 

 

  1. Open the SoundTouch app on a computer or mobile device connected to the same network as the NAS drive.
  2. In the app, tap the Menu icon in the upper-left.
  3. Tap Add Service.
  4. Tap Music Library on NAS.
  5. Tap your NAS drive to select it. Only drives accessible by the app can be selected. If the NAS drive doesn't appear, open the NAS drive settings menu, then look for and enable any media sharing options. After, go back to the Bose app and tap REFRESH to re-scan for available drives.
  6. Enter a name for your music library.
  7. Tap Add Music Library.

I look forward to hearing back from you. 

 

Kind Regards, 

Vicky W - Community Support 

 

 

 

 

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 7
  • 0
Registered since

Aug 28, 2017

Re: Error playing library on NAS

Hi Vicky,

 

Thank you for the reply.

 

I took those steps and the library is fully visible in the Soundtouch app. I can see all the music tracks in the app and I can play them via recently added and by album, just get the error when trying to play All Music

Highlighted
Participant
  • 0
  • 7
  • 0
Registered since

Aug 28, 2017

Re: Error playing library on NAS

My message was not very clear. Sorry.

 

The suggested steps haven’t fixed the problem, I am still getting the same errors