Highlighted
Participant
  • 0
  • 18
  • 0
Registered since

Jun 13, 2017

Frequently disconnecting the SA-5 and soundtouch 20

Hello Bose,

I am from Bulgaria /City: Varna/  I Have SoundTouch 20 and SA-5 with two bookshelf spekers 301.

I have writen aboute my problems probably for about 3rd time. The thing is that even after check in local service in Sofia the issue still exist. Namely:

1. I am loosing the connection between SA-5 and SoundTouch software

2. When both play SpundTouch 20 in the kitchen and SA-5 in the living room with online radio, very frequently they loose connection (only one of it or all together) and start searching.

3. Mostly they loose connection when they play all together simultaneously

Sometimes It works fine but not for a long time

Last time the error was 1064

What I've done till now

1.  Several restarts and disconect/connect with my router

2. Change with better router and switch to 5ghz network

3. Check in service in Sofia

 

With regret I share that If I knew early about this software issue I would choose another sound company for my home nevertheless the great sound of bose.

 

8 REPLIES 8
Highlighted
Moderator

Re: Frequently disconnecting the SA-5 and soundtouch 20

Hello IDYLLIST, 

 

Thanks for posting. 

 

I'm sorry to hear you're having issues with disconnections on your SoundTouch products.

 

Does this issue only occur if you try to play the speakers as a group? If so, this may be related to the bandwidth of your router or the RSSI level of the speakers. You can check RSSI quality by going into the SoundTouch app, Tap the menu button in the top left corner, tap "Settings" > About" then select the desired system to view its technical information. Signal strength is listed as "RSSI Signal Strength".

 

I recommend having the speaker with the best signal strength as the primary speaker in a group, so try switching between the 20 and the SA-5 as the main speaker to see if this improves performance. 

 

Please let me know how you get on.

 

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 18
  • 0
Registered since

Jun 13, 2017

Re: Frequently disconnecting the SA-5 and soundtouch 20

Hello,

 

Thank you for the prompt replay.

 

Regarding RSSI: Both SoundTouch20 and SA-5  RSSI is GREAT. But nevermind if they play in group or not SA-5 disconnecting all the time and more frequently than before. Soundtouch 20 doesn't disconnect like SA-5. Sometimes It stay in grey and I can't do anything. Then suddenly connection back for 2sec - 20sec and stop again. SoundTouch20 doesn't stop.

 

If SA-5 play alone also make disconection from the software and stop the music. It is realy annoying I can't listen online radio at all. In fact I can listen online radio only on SoundTouch20 in the kitchen

Sometimes apear error: 4004

It's written: "The speaker is ready to play" Then I try to play some radio and appear "Searching for speaker" and error 1043 press ok "Loading"... and again 1043... then It establish coonection for a short time and again.... the same

Highlighted
Moderator

Re: Frequently disconnecting the SA-5 and soundtouch 20

Thank you for clarifying, IDYLLIST.

 

How far from your WiFi router do you have the SA-5 and SoundTouch 20 speakers positioned? What is your current internet speed, and have you always been able to stream internet music through both systems, without issue in the past?

 

Also, it may be worth switching both systems to the 2.4GHz channel (better for longer distance streaming) and then rebooting your WiFi router, by disconnecting it from power for two minutes. Give that a try and let me know if you notice any improvement to the streaming quality!

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 18
  • 0
Registered since

Jun 13, 2017

Re: Frequently disconnecting the SA-5 and soundtouch 20

Hello again,

So... SA-5 is about 40-50cm from the router. SoundTouch20 is about 3-4m in straight line.

My current internet speed is 50mbt/s but not guarantee. And no I never had opportunity to stream internet music for a long time in the past. May be a little bit more than now. I will try to come back in 2.4ghz and let you know about the result. (Before was 2.4ghz and also disconnecting from the int.radio) Anyway I will try again.

 

Very often when SA-5 is connected by bluetooth to my PC the sound doesn't stop, but the software/program show "searching" just like that or error 4004. And become grey. SoundTouch20 doesn't loose the connection, but SA-5 loose. The music doesn't stop when it is bluetooth but on int.radio stop....

 

I will try 2.4ghz but I think it is something else. Help 😞

Highlighted
Moderator

Re: Frequently disconnecting the SA-5 and soundtouch 20

Thanks for coming back to us!

 

I also want to thank you for this information, this is super helpful in helping us determine what's going on. 

 

Based on the information you have provided, there are not any alarm bells that would indicate the cause of your issue. 

 

Let us know how it goes on the 2.4 gHz band and we will see where to go from here based on the results. 

 

I look forward to hearing from you!

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 18
  • 0
Registered since

Jun 13, 2017

Re: Frequently disconnecting the SA-5 and soundtouch 20

Hello again,

 

After 3 days working on 2.4ghz. The results:

It's seems better than 5ghz but not perfect.At least I can listen online radio for hours without disconnecting

In the beginning I had some issue with reinstalling the SA-5 and SoundToush20 on 2.4ghz. More precisely in discovering of the SA-5.

Now as I said It's work fine with some breaks, but without shwoing the previous errors. 4000 or 1064. And the breaks are for 2-3 sec and very seldom.

The other thing is that I don't exit from the programme, It is in my taskbar but when I maximize it  delay about 2-3 sec and I don't have any control. My PC is not old and it is with good characterization specialy for a such programme. This must be improve. I don't know how long it will work ok.

Last time for the same problem I bought a new router. Only to use 5ghz as a not so use up frequency.

Highlighted
Moderator

Re: Frequently disconnecting the SA-5 and soundtouch 20

Thanks for coming back to us! 

 

I'm glad to hear that the 2.4GHz band has improved your issue. 

 

Just to check, are you running any extenders or boosters?

 

I would also recommend checking your router settings. I have included the LINK HERE to a thread that should help with this. 

 

Let me know!

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 18
  • 0
Registered since

Jun 13, 2017

Re: Frequently disconnecting the SA-5 and soundtouch 20

Hello,

 

Regarding last message, What do you mean with extenders or boosters? It is just my router receiving the signal from internet and tv provider through optic cable.Between the router and provider is lan cable. Nothing else. And then my 2 bose system (using wifi)

I checked my router settings compare with the link but some of the described settings I couldn't find in my router.

Anyway now It is work better but still has some discconections showing some errors.  The positive is tha It is not disconnect very often.