Sound Touch 10 unresponsive

Highlighted
Silent Starter

Sound Touch 10 unresponsive

A Sound Touch 10 purchased about a year ago has become completely unresponsive. The blue led is blinking rapidly. I have tried unplugging it and waiting several minutes before plugging in again. I have also tried to reset (holding the - and 1 buttons) with no luck. Any ideas for what to try next?

2 REPLIES 2
Moderator

Re: Sound Touch 10 unresponsive

Hello wdclark, 


Welcome to the Bose Community, thanks for taking the time to post. 

 

I'm sorry to hear you are having issues with your SoundTouch 10 speaker. 

 

It sounds like you have already attempted a factory reset by holding the preset 1 and Volume down buttons together, so if the issue still persists, I'd recommend attempting to overwrite the current firmware with a fresh build. Instructions for this can be found here. 

 

If the speaker still does not work, please reach out to support in your country. Details can be found here.

 

If anyone else in the community is having similar issues, please try the above recommendations and feel free to join in the conversation. 

 

Kind regards,

Jeff G - Community Support

Audible Advocate

Re: Sound Touch 10 unresponsive

I have the same problem but I’ve given up and are not using this speaker. After the last update I’m also having problem getting my SoundTouch wireless link adapter to work with play all function. It lights up but is completely silent. Bose is not what it used to be.....