Highlighted
Contributor
  • 1
  • 12
  • 0
Registered since

Feb 16, 2020

SoundTouch 10's won't play thru wifi

I have three ST10's, none of them will connect to the network. Now, to be clear, they were connecting before, but then we did a network upgrade which required a new router. I have tried holding down #2 on them, the WiFi light never goes amber; I tried a simple reset, still doesn't connect; finally I tried a factory reset on one of them, no go. I can connect via bluetooth to my iPhone, but playing through it drains the iPhone quickly.

1 REPLY 1
Highlighted
Moderator

Re: SoundTouch 10's won't play thru wifi

Hello pahiker, 

 

Thanks for posting. 

 

I'm sorry to hear you're having issues setting up your speakers with your new network. For all speakers to not be connecting, this is definitely going to be an external issue, not the speakers themselves. 

 

I would recommend looking at our recommended router settings to ensure your router is set up to best work with network-based speakers. Details can be found here.

 

Once you've made these changes, I'd suggest factory resetting the speakers (Hold Preset 1 and Vol- together for around 10 seconds or until the lights flash) and set them up one by one.

 

Please let me know how you get on. 

 

 

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!