• 0
  • 1
  • 0
Registered since

Jan 11, 2021

SoundTouch 30 Series 1

Hello Everyone


I have the SoundTouch 30 series 1

I bought it on 2014 it was working fine until I tried to update it using the USB method


the update progress stopped at 50% and stopped progressing  and I though it was normal so I waited for an hour and still not moving, so I had to power it off

still the same problem after so many attempts.


but when I try to use the series lll software update it does complete the update smoothly.. but it doesn't work properly because it’s not made for it

so the problem is because of the update file..


did anyone have the same problem and solved it?


i hope someone have the old update file and can send it to me, all bose official websites have the newest one.


Thank you



Re: SoundTouch 30 Series 1

Hi Fuzzy2,


Thanks for posting and welcome to the Community!


If you have a SoundTouch 30 series I, then the update file for a series III should not install on the speaker correctly. What you mentioned about the 1st update file you tried stopping progressing after a certain point, is what I would expect to happen when you try and install an incorrect update file.


It would be worth double-checking which version of the SoundTouch 30 you have using the Find your product section of our support page HERE. Once you have confirmed which model you have, you can find the correct update file for the speaker HERE. There are update files for the SoundTouch 20 and 30 on this page, so make sure you choose the right one for your speaker!


Let me know how you get on!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!