Wouter1971
Participant
  • 4
  • 2
  • 0
Registered since

Feb 22, 2021

Re: SoundTouch 300 and Acoustimass 300 - Status Light Amber + White or Amber + White + Red

Talked to support. Last update was from Oktober 2020. System is going in for repair, they said they will escalate it to fix this permanently or exchange it. Sounds reasonable. 

maxpower_
Contributor
  • 8
  • 12
  • 0
Registered since

Feb 20, 2021

Re: SoundTouch 300 and Acoustimass 300 - Status Light Amber + White or Amber + White + Red

hey Wouter was this through email or did you end up calling? Mind hooking us up with a contact? Thanks a ton and yeah I really hope they fix this, it's frustrating not hearing anything back from Bose.

Rf75
Participant
  • 3
  • 2
  • 0
Registered since

Feb 22, 2021

Re: SoundTouch 300 and Acoustimass 300 - Status Light Amber + White or Amber + White + Red

Hi,

update from Norway,Called Support.

Sub is to be sent in for repair. Free of Charge incl shipping

Still under Warranty acc to Norwegian law ,that is 5 years after Purchase👍 

Temberg
Participant
  • 1
  • 1
  • 0
Registered since

Mar 2, 2021

Re: SoundTouch 300 and Acoustimass 300 - Status Light Amber + White or Amber + White + Red

I am having ecactly the same problem..

Tried every thing mentioned.

Sub not connecting. Blinking amber , White and red.

I`m contacting bose dealer to get it fixed.

maxpower_
Contributor
  • 8
  • 12
  • 0
Registered since

Feb 20, 2021

Re: SoundTouch 300 and Acoustimass 300 - Status Light Amber + White or Amber + White + Red

So I just called Bose and they want me to pay $150 USD (includes shipping) to have this thing sent in for 3 weeks, because it's "out of warranty". Are they kidding? This thing was working PERFECTLY fine until this last update and now I'm paying 150 bucks to fix their mistake? This is completely insane. The guy on the phone was helpful enough but man, this really pissed me off. I could throw down a few bucks extra and just get another one that isn't gonna stop working randomly! Bose, can you guys get in here and help us out? Where are you?

Andy_UK
Contributor
  • 8
  • 5
  • 0
Registered since

Feb 12, 2021

Re: SoundTouch 300 and Acoustimass 300 - Status Light Amber + White or Amber + White + Red

It is interesting to note that a number of the Bose moderators were quite active in this matter up until Christmas 2020 and then nothing. Where have they all gone? Have they been instructed to keep away from this one?

maxpower_
Contributor
  • 8
  • 12
  • 0
Registered since

Feb 20, 2021

Re: SoundTouch 300 and Acoustimass 300 - Status Light Amber + White or Amber + White + Red

Yep, noticed this too. Complete radio silence from Bose on this post and any subsequent posts regarding this very common issue. I still can't believe they were asking me to spend my own money to correct a problem they caused? It really is a slap in the face. I've just been staring at this giant black box sitting on my floor, flashing these lights, mocking me lmao idk, I'm sensing we might be sol at this point. Bose isn't really giving the impression that they're willing to work with us on a solution. Talk about a huge disappointment 😕

Pfunks
Enthusiast
  • 14
  • 40
  • 0
Registered since

May 9, 2019

Re: SoundTouch 300 and Acoustimass 300 - Status Light Amber + White or Amber + White + Red

It is strange that bose isn't communicating on this thread.  I'm guessing they want it to die off so they can freeze/lock the thread.  Die off like they're faulty subwoofers

maxpower_
Contributor
  • 8
  • 12
  • 0
Registered since

Feb 20, 2021

Re: SoundTouch 300 and Acoustimass 300 - Status Light Amber + White or Amber + White + Red

It's so disappointing considering how they're responding to so many threads, just not the ones where they've caused a problem with their own products and don't want to help us. Now they're telling their customers to pay for bricking the sub with an update they issued. Unreal.

htims1989
Contributor
  • 5
  • 8
  • 0
Registered since

Dec 27, 2019

Re: SoundTouch 300 and Acoustimass 300 - Status Light Amber + White or Amber + White + Red

This has happened to a family members Acoustimass 300 immediately after doing an update, it was fine before.

 

Has anyone tried to downgrade the firmware back to the previous version? I guess that getting it to apply to the Acoustimass could be problematic since it connects to the soundbar wirelessly to get the update and that's the problem here (connectivity to the soundbar)! Does anyone have a copy of the previous version of the firmware? Struggling to find it, the manual update pages (https://www.bose.co.uk/en_gb/support/article/updating-soundtouch-300.html) seem to only have links to the latest version and it seems like I'd need to know the exact name of the previous in order to download it (if they haven't removed it!).