Participant
  • 0
  • 1
  • 0
Registered since

Nov 13, 2019

Soundtouch 20 series II failed connection to network

Just got a Soundtouch 20 series II from a friend. Problem is, the speaker can’t connect to my home or office network. Whenever I try setting it up, it always get derailed and all I get is that screen “please wait” I’ve tried setting up using Wifi and Ethernet with the same result. 

1 REPLY 1
Moderator

Re: Soundtouch 20 series II failed connection to network

Hey andrewmarcella,

 

Thanks for reaching out via the Bose Community. Welcome to the site!

 

I'm sorry to hear you are having issues setting up your SoundTouch 20 II system. I would recommend trying the following in an attempt to resolve this:

 

Reset the system

 

After booting the system up, press and hold the Preset 1 and Volume down buttons together for around 10 seconds. Once the reset has completed, the WiFi icon will appear above the display in orange.

 

 

Ensure you are connecting to the correct network

 

The SoundTouch 20 II supports only B and G band networks. If you are using a dual-band router that operates on both 2.4Ghz and 5Ghz bands, I would recommend separating the bands (refer to your router's user guide for instructions) and ensure you set up with the 2.4Ghz SSID in mind as this supports B and G bands. I would also recommend making sure the smartphone/device you are using for setup is connected to this specific SSID by default beforehand. 

 

 

Update the firmware

 

If the speaker hasn't been updated for a while, you may find the speaker does not work with the app, or cannot be updated within the app. If this is the case, you can perform a manual update by visiting this link.

 

 

If the issue persists, please feel free to get back in touch.

 

Kind regards, 

 

Jeff G - Community Support

 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!