Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Jul 25, 2020

Soundtouch 20 status bar no progress

My soundtouch 20 stopped working. All that happens when I turn it on is the status bar appears and makes no progress. 

I have put a usb stick in with the new firmware, didnt work.

I have tried connecting my computer to it, didnt work.

I have held 4 and volume as well as 2 and volume, neither worked.  

 

I do not own an echo dot, so I have not tried that fix.

I'm pretty frustrated and want this thing to work again. Please help.

 

 

1 REPLY 1
Highlighted
Moderator

Re: Soundtouch 20 status bar no progress

Hi Jasonjgstevens,

 

Thanks for posting and joining us in the community!

 

It sounds like you are doing some great troubleshooting for this already, so thank you for doing that and letting us know! Attempting to manually update the speaker is a great step to take to try and resolve this!

 

I'm not sure what you mean by a fix using an echo dot, could you let me know what this would involve?

 

If the bar still isn't moving after doing this troubleshooting, the next thing I would recommend trying is to factory reset the speaker. To do this what you will want to do is press and hold the number 1 and volume down together for 10 seconds.

 

Let me know how you get on!

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!