Highlighted
Participant
  • 0
  • 2
  • 0
Registered since

Sep 6, 2020

How do I make sure A2DP profile is enabled and make Soundwear connect through it on Windows 10?

My Soundwear has degraded sound quality and it only shows up as handsfree device or stereo headphones in its supported audio services section in its Bluetooth device control window.

 

A couple of years ago, I remember I could enjoy Soundwear's deep base and loud volume, usually around 30 out of 100 (Win 10 volume number). Now, there is no base at all and I have to raise its volume to 100 to make it enjoyable. (Not sure what made this change though, possibly a Windows reinstallation.)

 

I searched a lot and it seems like it is not connecting through A2DP profile. But I cannot find any direct reference to the profile in anywhere in Windows sound control. Does anyone know how I can make sure the profile is available and how I can make Soundwear connect through it?

3 REPLIES 3
Highlighted
Moderator

Re: How do I make sure A2DP profile is enabled and make Soundwear connect through it on Windows 10?

Hello,

 

Thanks for reaching out! 

 

I'm sorry to hear you're having issues with your SoundWear Companion. 

 

When paired to your computer, A2DP will be displayed as Stereo Headphones. You need to ensure you select this as the audio output as Handfree (HSP/HFP profiles) is designed for calls and has a more limited audio frequency range at the low and high frequency ends. You can check which output your speaker is set to by clicking the speaker icon in your taskbar. It'll show the currently selected output. Tap the arrow to make changes. 

 

If you're connected to "stereo headphones" and still experience inadequate audio quality, try clearing the device list, then create a new pairing. This can help to remove any minor software bugs. 

 

If you continue to have problems, please attempt to update the firmware. 

 

Please let me know how you get on. 😊

 

 

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 2
  • 0
Registered since

Sep 6, 2020

Re: How do I make sure A2DP profile is enabled and make Soundwear connect through it on Windows 10?

Thank you for your response. My Soundwear only shows up as a hands-free device. If a stereo output was showing up separately, I would've simply disabled the hands-free output, but the hands-free one is the only sound output that is showing.

That's why I originally asked a way to force the connection to go through A2DP.

Moreover, if I want to disconnect it and reconnect without rebooting the computer, I have to remove it from the saved pairing device list and rediscover and reconnect it. 

Highlighted
Moderator

Re: How do I make sure A2DP profile is enabled and make Soundwear connect through it on Windows 10?

When you say that you have to remove it from the saved pairing list, is this from your computer's Bluetooth list? I'd also recommend clearing the pairing list on the SoundWear itself. You can do this by holding the Bluetooth button for 10 seconds until you hear a tone. Delete the speaker from your computer's Bluetooth list again and then try to establish a fresh connection.

 

Let me know if you're then able to see the stereo profile again.

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!